open-falcon 安装过程

    [[email?protected] ~]# yum install wget -y
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock error was
    12: Timeout on http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
    epel/x86_64/metalink                                                                                                                         | 6.7 kB  00:00:00     
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    base                                                                                                                                         | 3.6 kB  00:00:00     
    epel                                                                                                                                         | 4.7 kB  00:00:00     
    http://fedora.cs.nctu.edu.tw/epel/7/x86_64/repodata/repomd.xml: [Errno -1] repomd.xml does not match metalink for epel
    正在尝试其它镜像。
    epel                                                                                                                                         | 5.4 kB  00:00:00     
    extras                                                                                                                                       | 2.9 kB  00:00:00     
    updates                                                                                                                                      | 2.9 kB  00:00:00     
    epel/x86_64/primary_db         FAILED                                                                                             ]  0.0 B/s |    0 B  --:--:-- ETA 
    http://ftp.jaist.ac.jp/pub/Linux/Fedora/epel/7/x86_64/repodata/2ddb9d9c2c0f9ac8d5af1f933484982aa5c7ad2d2c6bf07032f659774ddb02c9-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found
    正在尝试其它镜像。
    To address this issue please refer to the below wiki article 

    https://wiki.centos.org/yum-errors

    If above article does not help to resolve this issue please use https://bugs.centos.org/.

    (1/4): extras/7/x86_64/primary_db                                                                                                            | 152 kB  00:00:01     
    epel/x86_64/primary_db         FAILED                                          
    https://nrt.edge.kernel.org/fedora-buffet/epel/7/x86_64/repodata/2ddb9d9c2c0f9ac8d5af1f933484982aa5c7ad2d2c6bf07032f659774ddb02c9-primary.sqlite.bz2: [Errno 14] HTTPS Error 404 - Not Found
    正在尝试其它镜像。
    (2/4): epel/x86_64/updateinfo                                                                                                                | 1.0 MB  00:00:07     
    (3/4): updates/7/x86_64/primary_db                                                                                                           | 1.1 MB  00:00:07     
    (4/4): epel/x86_64/primary_db                                                                                                                | 6.8 MB  00:00:30     
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 wget.x86_64.0.1.14-18.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                              架构                                   版本                                        源                                    大小
    ====================================================================================================================================================================
    正在安装:
    wget                                 x86_64                                 1.14-18.el7                                 base                                 547 k

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包

    总下载量:547 k
    安装大小:2.0 M
    Downloading packages:
    wget-1.14-18.el7.x86_64.rpm                                                                                                                  | 547 kB  00:00:01     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在安装    : wget-1.14-18.el7.x86_64                                                                                                                         1/1 
    验证中      : wget-1.14-18.el7.x86_64                                                                                                                         1/1 

    已安装:
    wget.x86_64 0:1.14-18.el7                                                                                                                                         

    完毕!
    [[email?protected] ~]# yum install git telnet net-tools tree nmap sysstat lrzsz dos2unix tcpdump ntpdate -y
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    软件包 net-tools-2.0-0.24.20131004git.el7.x86_64 已安装并且是最新版本
    软件包 lrzsz-0.12.20-36.el7.x86_64 已安装并且是最新版本
    软件包 ntpdate-4.2.6p5-28.el7.centos.x86_64 已安装并且是最新版本
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 dos2unix.x86_64.0.6.0.3-7.el7 将被 安装
    ---> 软件包 git.x86_64.0.1.8.3.1-19.el7 将被 安装
    --> 正在处理依赖关系 perl-Git = 1.8.3.1-19.el7,它被软件包 git-1.8.3.1-19.el7.x86_64 需要
    --> 正在处理依赖关系 perl(Term::ReadKey),它被软件包 git-1.8.3.1-19.el7.x86_64 需要
    --> 正在处理依赖关系 perl(Git),它被软件包 git-1.8.3.1-19.el7.x86_64 需要
    --> 正在处理依赖关系 perl(Error),它被软件包 git-1.8.3.1-19.el7.x86_64 需要
    ---> 软件包 nmap.x86_64.2.6.40-16.el7 将被 安装
    --> 正在处理依赖关系 nmap-ncat = 2:6.40-16.el7,它被软件包 2:nmap-6.40-16.el7.x86_64 需要
    --> 正在处理依赖关系 libpcap.so.1()(64bit),它被软件包 2:nmap-6.40-16.el7.x86_64 需要
    ---> 软件包 sysstat.x86_64.0.10.1.5-17.el7 将被 安装
    --> 正在处理依赖关系 libsensors.so.4()(64bit),它被软件包 sysstat-10.1.5-17.el7.x86_64 需要
    ---> 软件包 tcpdump.x86_64.14.4.9.2-3.el7 将被 安装
    ---> 软件包 telnet.x86_64.1.0.17-64.el7 将被 安装
    ---> 软件包 tree.x86_64.0.1.6.0-10.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 libpcap.x86_64.14.1.5.3-11.el7 将被 安装
    ---> 软件包 lm_sensors-libs.x86_64.0.3.4.0-6.20160601gitf9185e5.el7 将被 安装
    ---> 软件包 nmap-ncat.x86_64.2.6.40-16.el7 将被 安装
    ---> 软件包 perl-Error.noarch.1.0.17020-2.el7 将被 安装
    ---> 软件包 perl-Git.noarch.0.1.8.3.1-19.el7 将被 安装
    ---> 软件包 perl-TermReadKey.x86_64.0.2.30-20.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                  架构                           版本                                                    源                            大小
    ====================================================================================================================================================================
    正在安装:
    dos2unix                                 x86_64                         6.0.3-7.el7                                             base                          74 k
    git                                      x86_64                         1.8.3.1-19.el7                                          base                         4.4 M
    nmap                                     x86_64                         2:6.40-16.el7                                           base                         3.9 M
    sysstat                                  x86_64                         10.1.5-17.el7                                           base                         315 k
    tcpdump                                  x86_64                         14:4.9.2-3.el7                                          base                         421 k
    telnet                                   x86_64                         1:0.17-64.el7                                           base                          64 k
    tree                                     x86_64                         1.6.0-10.el7                                            base                          46 k
    为依赖而安装:
    libpcap                                  x86_64                         14:1.5.3-11.el7                                         base                         138 k
    lm_sensors-libs                          x86_64                         3.4.0-6.20160601gitf9185e5.el7                          base                          42 k
    nmap-ncat                                x86_64                         2:6.40-16.el7                                           base                         206 k
    perl-Error                               noarch                         1:0.17020-2.el7                                         base                          32 k
    perl-Git                                 noarch                         1.8.3.1-19.el7                                          base                          55 k
    perl-TermReadKey                         x86_64                         2.30-20.el7                                             base                          31 k

    事务概要
    ====================================================================================================================================================================
    安装  7 软件包 (+6 依赖软件包)

    总下载量:9.7 M
    安装大小:42 M
    Downloading packages:
    (1/13): lm_sensors-libs-3.4.0-6.20160601gitf9185e5.el7.x86_64.rpm                                                                            |  42 kB  00:00:00     
    (2/13): dos2unix-6.0.3-7.el7.x86_64.rpm                                                                                                      |  74 kB  00:00:01     
    (3/13): libpcap-1.5.3-11.el7.x86_64.rpm                                                                                                      | 138 kB  00:00:01     
    (4/13): perl-Error-0.17020-2.el7.noarch.rpm                                                                                                  |  32 kB  00:00:00     
    (5/13): perl-TermReadKey-2.30-20.el7.x86_64.rpm                                                                                              |  31 kB  00:00:00     
    (6/13): nmap-ncat-6.40-16.el7.x86_64.rpm                                                                                                     | 206 kB  00:00:01     
    (7/13): perl-Git-1.8.3.1-19.el7.noarch.rpm                                                                                                   |  55 kB  00:00:01     
    (8/13): telnet-0.17-64.el7.x86_64.rpm                                                                                                        |  64 kB  00:00:02     
    (9/13): sysstat-10.1.5-17.el7.x86_64.rpm                                                                                                     | 315 kB  00:00:03     
    (10/13): tcpdump-4.9.2-3.el7.x86_64.rpm                                                                                                      | 421 kB  00:00:03     
    (11/13): tree-1.6.0-10.el7.x86_64.rpm                                                                                                        |  46 kB  00:00:00     
    (12/13): nmap-6.40-16.el7.x86_64.rpm                                                                                                         | 3.9 MB  00:00:14     
    (13/13): git-1.8.3.1-19.el7.x86_64.rpm                                                                                                       | 4.4 MB  00:00:21     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                454 kB/s | 9.7 MB  00:00:21     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在安装    : 14:libpcap-1.5.3-11.el7.x86_64                                                                                                                 1/13 
    正在安装    : 1:perl-Error-0.17020-2.el7.noarch                                                                                                              2/13 
    正在安装    : 2:nmap-ncat-6.40-16.el7.x86_64                                                                                                                 3/13 
    正在安装    : lm_sensors-libs-3.4.0-6.20160601gitf9185e5.el7.x86_64                                                                                          4/13 
    正在安装    : perl-TermReadKey-2.30-20.el7.x86_64                                                                                                            5/13 
    正在安装    : perl-Git-1.8.3.1-19.el7.noarch                                                                                                                 6/13 
    正在安装    : git-1.8.3.1-19.el7.x86_64                                                                                                                      7/13 
    正在安装    : sysstat-10.1.5-17.el7.x86_64                                                                                                                   8/13 
    正在安装    : 2:nmap-6.40-16.el7.x86_64                                                                                                                      9/13 
    正在安装    : 14:tcpdump-4.9.2-3.el7.x86_64                                                                                                                 10/13 
    正在安装    : tree-1.6.0-10.el7.x86_64                                                                                                                      11/13 
    正在安装    : dos2unix-6.0.3-7.el7.x86_64                                                                                                                   12/13 
    正在安装    : 1:telnet-0.17-64.el7.x86_64                                                                                                                   13/13 
    验证中      : 1:telnet-0.17-64.el7.x86_64                                                                                                                    1/13 
    验证中      : 2:nmap-6.40-16.el7.x86_64                                                                                                                      2/13 
    验证中      : dos2unix-6.0.3-7.el7.x86_64                                                                                                                    3/13 
    验证中      : perl-TermReadKey-2.30-20.el7.x86_64                                                                                                            4/13 
    验证中      : lm_sensors-libs-3.4.0-6.20160601gitf9185e5.el7.x86_64                                                                                          5/13 
    验证中      : 1:perl-Error-0.17020-2.el7.noarch                                                                                                              6/13 
    验证中      : perl-Git-1.8.3.1-19.el7.noarch                                                                                                                 7/13 
    验证中      : git-1.8.3.1-19.el7.x86_64                                                                                                                      8/13 
    验证中      : 14:tcpdump-4.9.2-3.el7.x86_64                                                                                                                  9/13 
    验证中      : tree-1.6.0-10.el7.x86_64                                                                                                                      10/13 
    验证中      : 14:libpcap-1.5.3-11.el7.x86_64                                                                                                                11/13 
    验证中      : 2:nmap-ncat-6.40-16.el7.x86_64                                                                                                                12/13 
    验证中      : sysstat-10.1.5-17.el7.x86_64                                                                                                                  13/13 

    已安装:
    dos2unix.x86_64 0:6.0.3-7.el7    git.x86_64 0:1.8.3.1-19.el7    nmap.x86_64 2:6.40-16.el7    sysstat.x86_64 0:10.1.5-17.el7    tcpdump.x86_64 14:4.9.2-3.el7   
    telnet.x86_64 1:0.17-64.el7      tree.x86_64 0:1.6.0-10.el7    

    作为依赖被安装:
    libpcap.x86_64 14:1.5.3-11.el7     lm_sensors-libs.x86_64 0:3.4.0-6.20160601gitf9185e5.el7   nmap-ncat.x86_64 2:6.40-16.el7   perl-Error.noarch 1:0.17020-2.el7  
    perl-Git.noarch 0:1.8.3.1-19.el7   perl-TermReadKey.x86_64 0:2.30-20.el7                    

    完毕!
    [[email?protected] ~]# ntpdate cn.pool.ntp.org
    18 Sep 16:39:51 ntpdate[12924]: adjust time server 119.28.183.184 offset -0.005330 sec
    [[email?protected] ~]# sed -i 's#keepcache=0#keepcache=1#g' /etc/yum.conf 
    [[email?protected] ~]# grep keepcache /etc/yum.conf
    keepcache=1
    [[email?protected] ~]# sed -i 's/SELINUX=enforcing/SELINUX=disabled/g' /etc/selinux/config
    [[email?protected] ~]# setenforce 0
    [[email?protected] ~]# systemctl stop firewalld.service
    [[email?protected] ~]# systemctl disable firewalld.service
    [[email?protected] ~]# yum install redis -y
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    epel/x86_64/metalink                                                                                                                         | 6.4 kB  00:00:00     
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    base                                                                                                                                         | 3.6 kB  00:00:00     
    epel                                                                                                                                         | 5.4 kB  00:00:00     
    extras                                                                                                                                       | 2.9 kB  00:00:00     
    updates                                                                                                                                      | 2.9 kB  00:00:00     
    (1/2): base/7/x86_64/group_gz                                                                                                                | 165 kB  00:00:01     
    (2/2): base/7/x86_64/primary_db                                                                                                              | 6.0 MB  00:00:15     
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 redis.x86_64.0.3.2.12-2.el7 将被 安装
    --> 正在处理依赖关系 libjemalloc.so.1()(64bit),它被软件包 redis-3.2.12-2.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 jemalloc.x86_64.0.3.6.0-1.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                架构                                 版本                                          源                                  大小
    ====================================================================================================================================================================
    正在安装:
    redis                                  x86_64                               3.2.12-2.el7                                  epel                               544 k
    为依赖而安装:
    jemalloc                               x86_64                               3.6.0-1.el7                                   epel                               105 k

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包 (+1 依赖软件包)

    总下载量:648 k
    安装大小:1.7 M
    Downloading packages:
    (1/2): jemalloc-3.6.0-1.el7.x86_64.rpm                                                                                                       | 105 kB  00:00:00     
    (2/2): redis-3.2.12-2.el7.x86_64.rpm                                                                                                         | 544 kB  00:00:02     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                214 kB/s | 648 kB  00:00:03     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在安装    : jemalloc-3.6.0-1.el7.x86_64                                                                                                                     1/2 
    正在安装    : redis-3.2.12-2.el7.x86_64                                                                                                                       2/2 
    验证中      : redis-3.2.12-2.el7.x86_64                                                                                                                       1/2 
    验证中      : jemalloc-3.6.0-1.el7.x86_64                                                                                                                     2/2 

    已安装:
    redis.x86_64 0:3.2.12-2.el7                                                                                                                                       

    作为依赖被安装:
    jemalloc.x86_64 0:3.6.0-1.el7                                                                                                                                     

    完毕!
    [[email?protected] ~]# systemctl start redis
    [[email?protected] ~]# systemctl enable redis
    Created symlink from /etc/systemd/system/multi-user.target.wants/redis.service to /usr/lib/systemd/system/redis.service.
    [[email?protected] ~]# systemctl status redis
    ● redis.service - Redis persistent key-value database
    Loaded: loaded (/usr/lib/systemd/system/redis.service; enabled; vendor preset: disabled)
    Drop-In: /etc/systemd/system/redis.service.d
            └─limit.conf
    Active: active (running) since 三 2019-09-18 16:43:41 CST; 19s ago
    Main PID: 13021 (redis-server)
    CGroup: /system.slice/redis.service
            └─13021 /usr/bin/redis-server 127.0.0.1:6379

    9月 18 16:43:41 mgr systemd[1]: Starting Redis persistent key-value database...
    9月 18 16:43:41 mgr systemd[1]: Started Redis persistent key-value database.
    [[email?protected] ~]# yum install mariadb mariadb-server -y
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 mariadb.x86_64.1.5.5.64-1.el7 将被 安装
    --> 正在处理依赖关系 mariadb-libs(x86-64) = 1:5.5.64-1.el7,它被软件包 1:mariadb-5.5.64-1.el7.x86_64 需要
    ---> 软件包 mariadb-server.x86_64.1.5.5.64-1.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 mariadb-libs.x86_64.1.5.5.60-1.el7_5 将被 升级
    ---> 软件包 mariadb-libs.x86_64.1.5.5.64-1.el7 将被 更新
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                    架构                               版本                                          源                                大小
    ====================================================================================================================================================================
    正在安装:
    mariadb                                    x86_64                             1:5.5.64-1.el7                                base                             8.7 M
    mariadb-server                             x86_64                             1:5.5.64-1.el7                                base                              11 M
    为依赖而更新:
    mariadb-libs                               x86_64                             1:5.5.64-1.el7                                base                             759 k

    事务概要
    ====================================================================================================================================================================
    安装  2 软件包
    升级           ( 1 依赖软件包)

    总下载量:21 M
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    (1/3): mariadb-libs-5.5.64-1.el7.x86_64.rpm                                                                                                  | 759 kB  00:00:08     
    (2/3): mariadb-5.5.64-1.el7.x86_64.rpm                                                                                                       | 8.7 MB  00:00:40     
    (3/3): mariadb-server-5.5.64-1.el7.x86_64.rpm                                                                                                |  11 MB  00:00:52     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                406 kB/s |  21 MB  00:00:52     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在更新    : 1:mariadb-libs-5.5.64-1.el7.x86_64                                                                                                              1/4 
    正在安装    : 1:mariadb-5.5.64-1.el7.x86_64                                                                                                                   2/4 
    正在安装    : 1:mariadb-server-5.5.64-1.el7.x86_64                                                                                                            3/4 
    清理        : 1:mariadb-libs-5.5.60-1.el7_5.x86_64                                                                                                            4/4 
    验证中      : 1:mariadb-libs-5.5.64-1.el7.x86_64                                                                                                              1/4 
    验证中      : 1:mariadb-5.5.64-1.el7.x86_64                                                                                                                   2/4 
    验证中      : 1:mariadb-server-5.5.64-1.el7.x86_64                                                                                                            3/4 
    验证中      : 1:mariadb-libs-5.5.60-1.el7_5.x86_64                                                                                                            4/4 

    已安装:
    mariadb.x86_64 1:5.5.64-1.el7                                                 mariadb-server.x86_64 1:5.5.64-1.el7                                                

    作为依赖被升级:
    mariadb-libs.x86_64 1:5.5.64-1.el7                                                                                                                                

    完毕!
    [[email?protected] ~]# systemctl start mariadb
    [[email?protected] ~]# systemctl enable mariadb
    Created symlink from /etc/systemd/system/multi-user.target.wants/mariadb.service to /usr/lib/systemd/system/mariadb.service.
    [[email?protected] ~]# mysql -uroot -p
    Enter password: 
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 2
    Server version: 5.5.64-MariaDB MariaDB Server

    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    MariaDB [(none)]> exit
    Bye
    [[email?protected] ~]# cd /tmp/
    [[email?protected] tmp]# rz
    rz waiting to receive.
    Starting zmodem transfer.  Press Ctrl+C to cancel.
    Transferring 1_uic-db-schema.sql...
    100%       1 KB       1 KB/sec    00:00:01       0 Errors  
    Transferring 2_portal-db-schema.sql...
    100%       7 KB       7 KB/sec    00:00:01       0 Errors  
    Transferring 3_dashboard-db-schema.sql...
    100%       3 KB       3 KB/sec    00:00:01       0 Errors  
    Transferring 4_graph-db-schema.sql...
    100%       1 KB       1 KB/sec    00:00:01       0 Errors  
    Transferring 5_alarms-db-schema.sql...
    100%       2 KB       2 KB/sec    00:00:01       0 Errors  

    [[email?protected] tmp]# mysql   
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 14
    Server version: 5.5.64-MariaDB MariaDB Server

    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    MariaDB [(none)]> show databases;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | mysql              |
    | performance_schema |
    | test               |
    +--------------------+
    4 rows in set (0.00 sec)

    MariaDB [(none)]> exit
    Bye
    [[email?protected] tmp]# for sqlfile in `ls |grep sql`; do mysql < $sqlfile ;done;
    [[email?protected] tmp]# mysql
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 20
    Server version: 5.5.64-MariaDB MariaDB Server

    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    MariaDB [(none)]> show databases;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | alarms             |
    | dashboard          |
    | falcon_portal      |
    | graph              |
    | mysql              |
    | performance_schema |
    | test               |
    | uic                |
    +--------------------+
    9 rows in set (0.00 sec)

    MariaDB [(none)]> exit
    Bye
    [[email?protected] tmp]# yum install golang 
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 golang.x86_64.0.1.11.5-1.el7 将被 安装
    --> 正在处理依赖关系 golang-bin = 1.11.5-1.el7,它被软件包 golang-1.11.5-1.el7.x86_64 需要
    --> 正在处理依赖关系 golang-src = 1.11.5-1.el7,它被软件包 golang-1.11.5-1.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 golang-bin.x86_64.0.1.11.5-1.el7 将被 安装
    --> 正在处理依赖关系 gcc,它被软件包 golang-bin-1.11.5-1.el7.x86_64 需要
    --> 正在处理依赖关系 subversion,它被软件包 golang-bin-1.11.5-1.el7.x86_64 需要
    --> 正在处理依赖关系 mercurial,它被软件包 golang-bin-1.11.5-1.el7.x86_64 需要
    ---> 软件包 golang-src.noarch.0.1.11.5-1.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 gcc.x86_64.0.4.8.5-39.el7 将被 安装
    --> 正在处理依赖关系 libgomp = 4.8.5-39.el7,它被软件包 gcc-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 cpp = 4.8.5-39.el7,它被软件包 gcc-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libgcc >= 4.8.5-39.el7,它被软件包 gcc-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 glibc-devel >= 2.2.90-12,它被软件包 gcc-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libmpfr.so.4()(64bit),它被软件包 gcc-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libmpc.so.3()(64bit),它被软件包 gcc-4.8.5-39.el7.x86_64 需要
    ---> 软件包 mercurial.x86_64.0.2.6.2-10.el7 将被 安装
    ---> 软件包 subversion.x86_64.0.1.7.14-14.el7 将被 安装
    --> 正在处理依赖关系 subversion-libs(x86-64) = 1.7.14-14.el7,它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_wc-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_subr-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_repos-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_ra_svn-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_ra_neon-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_ra_local-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_ra-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_fs_util-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_fs_fs-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_fs_base-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_fs-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_diff-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_delta-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libsvn_client-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libneon.so.27()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libaprutil-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在处理依赖关系 libapr-1.so.0()(64bit),它被软件包 subversion-1.7.14-14.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 apr.x86_64.0.1.4.8-5.el7 将被 安装
    ---> 软件包 apr-util.x86_64.0.1.5.2-6.el7 将被 安装
    ---> 软件包 cpp.x86_64.0.4.8.5-39.el7 将被 安装
    ---> 软件包 glibc-devel.x86_64.0.2.17-292.el7 将被 安装
    --> 正在处理依赖关系 glibc-headers = 2.17-292.el7,它被软件包 glibc-devel-2.17-292.el7.x86_64 需要
    --> 正在处理依赖关系 glibc = 2.17-292.el7,它被软件包 glibc-devel-2.17-292.el7.x86_64 需要
    --> 正在处理依赖关系 glibc-headers,它被软件包 glibc-devel-2.17-292.el7.x86_64 需要
    ---> 软件包 libgcc.x86_64.0.4.8.5-36.el7 将被 升级
    ---> 软件包 libgcc.x86_64.0.4.8.5-39.el7 将被 更新
    ---> 软件包 libgomp.x86_64.0.4.8.5-36.el7 将被 升级
    ---> 软件包 libgomp.x86_64.0.4.8.5-39.el7 将被 更新
    ---> 软件包 libmpc.x86_64.0.1.0.1-3.el7 将被 安装
    ---> 软件包 mpfr.x86_64.0.3.1.1-4.el7 将被 安装
    ---> 软件包 neon.x86_64.0.0.30.0-4.el7 将被 安装
    --> 正在处理依赖关系 libgnutls.so.28(GNUTLS_3_0_0)(64bit),它被软件包 neon-0.30.0-4.el7.x86_64 需要
    --> 正在处理依赖关系 libgnutls.so.28(GNUTLS_2_12)(64bit),它被软件包 neon-0.30.0-4.el7.x86_64 需要
    --> 正在处理依赖关系 libgnutls.so.28(GNUTLS_1_4)(64bit),它被软件包 neon-0.30.0-4.el7.x86_64 需要
    --> 正在处理依赖关系 libproxy.so.1()(64bit),它被软件包 neon-0.30.0-4.el7.x86_64 需要
    --> 正在处理依赖关系 libpakchois.so.0()(64bit),它被软件包 neon-0.30.0-4.el7.x86_64 需要
    --> 正在处理依赖关系 libgnutls.so.28()(64bit),它被软件包 neon-0.30.0-4.el7.x86_64 需要
    ---> 软件包 subversion-libs.x86_64.0.1.7.14-14.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 glibc.x86_64.0.2.17-260.el7 将被 升级
    --> 正在处理依赖关系 glibc = 2.17-260.el7,它被软件包 glibc-common-2.17-260.el7.x86_64 需要
    ---> 软件包 glibc.x86_64.0.2.17-292.el7 将被 更新
    ---> 软件包 glibc-headers.x86_64.0.2.17-292.el7 将被 安装
    --> 正在处理依赖关系 kernel-headers >= 2.2.1,它被软件包 glibc-headers-2.17-292.el7.x86_64 需要
    --> 正在处理依赖关系 kernel-headers,它被软件包 glibc-headers-2.17-292.el7.x86_64 需要
    ---> 软件包 gnutls.x86_64.0.3.3.29-9.el7_6 将被 安装
    --> 正在处理依赖关系 trousers >= 0.3.11.2,它被软件包 gnutls-3.3.29-9.el7_6.x86_64 需要
    --> 正在处理依赖关系 libnettle.so.4()(64bit),它被软件包 gnutls-3.3.29-9.el7_6.x86_64 需要
    --> 正在处理依赖关系 libhogweed.so.2()(64bit),它被软件包 gnutls-3.3.29-9.el7_6.x86_64 需要
    ---> 软件包 libproxy.x86_64.0.0.4.11-11.el7 将被 安装
    --> 正在处理依赖关系 libmodman.so.1()(64bit),它被软件包 libproxy-0.4.11-11.el7.x86_64 需要
    ---> 软件包 pakchois.x86_64.0.0.4-10.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 glibc-common.x86_64.0.2.17-260.el7 将被 升级
    ---> 软件包 glibc-common.x86_64.0.2.17-292.el7 将被 更新
    ---> 软件包 kernel-headers.x86_64.0.3.10.0-1062.1.1.el7 将被 安装
    ---> 软件包 libmodman.x86_64.0.2.0.1-8.el7 将被 安装
    ---> 软件包 nettle.x86_64.0.2.7.1-8.el7 将被 安装
    ---> 软件包 trousers.x86_64.0.0.3.14-2.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                   架构                             版本                                            源                                 大小
    ====================================================================================================================================================================
    正在安装:
    golang                                    x86_64                           1.11.5-1.el7                                    epel                              631 k
    为依赖而安装:
    apr                                       x86_64                           1.4.8-5.el7                                     base                              103 k
    apr-util                                  x86_64                           1.5.2-6.el7                                     base                               92 k
    cpp                                       x86_64                           4.8.5-39.el7                                    base                              5.9 M
    gcc                                       x86_64                           4.8.5-39.el7                                    base                               16 M
    glibc-devel                               x86_64                           2.17-292.el7                                    base                              1.1 M
    glibc-headers                             x86_64                           2.17-292.el7                                    base                              687 k
    gnutls                                    x86_64                           3.3.29-9.el7_6                                  base                              680 k
    golang-bin                                x86_64                           1.11.5-1.el7                                    epel                               90 M
    golang-src                                noarch                           1.11.5-1.el7                                    epel                              6.4 M
    kernel-headers                            x86_64                           3.10.0-1062.1.1.el7                             updates                           8.7 M
    libmodman                                 x86_64                           2.0.1-8.el7                                     base                               28 k
    libmpc                                    x86_64                           1.0.1-3.el7                                     base                               51 k
    libproxy                                  x86_64                           0.4.11-11.el7                                   base                               64 k
    mercurial                                 x86_64                           2.6.2-10.el7                                    base                              2.6 M
    mpfr                                      x86_64                           3.1.1-4.el7                                     base                              203 k
    neon                                      x86_64                           0.30.0-4.el7                                    base                              166 k
    nettle                                    x86_64                           2.7.1-8.el7                                     base                              327 k
    pakchois                                  x86_64                           0.4-10.el7                                      base                               14 k
    subversion                                x86_64                           1.7.14-14.el7                                   base                              1.0 M
    subversion-libs                           x86_64                           1.7.14-14.el7                                   base                              922 k
    trousers                                  x86_64                           0.3.14-2.el7                                    base                              289 k
    为依赖而更新:
    glibc                                     x86_64                           2.17-292.el7                                    base                              3.6 M
    glibc-common                              x86_64                           2.17-292.el7                                    base                               11 M
    libgcc                                    x86_64                           4.8.5-39.el7                                    base                              102 k
    libgomp                                   x86_64                           4.8.5-39.el7                                    base                              158 k

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包 (+21 依赖软件包)
    升级           (  4 依赖软件包)

    总计:152 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在更新    : libgcc-4.8.5-39.el7.x86_64                                                                                                                     1/30 
    正在更新    : glibc-2.17-292.el7.x86_64                                                                                                                      2/30 
    warning: /etc/nsswitch.conf created as /etc/nsswitch.conf.rpmnew
    正在更新    : glibc-common-2.17-292.el7.x86_64                                                                                                               3/30 
    正在安装    : apr-1.4.8-5.el7.x86_64                                                                                                                         4/30 
    正在安装    : mpfr-3.1.1-4.el7.x86_64                                                                                                                        5/30 
    正在安装    : libmpc-1.0.1-3.el7.x86_64                                                                                                                      6/30 
    正在安装    : apr-util-1.5.2-6.el7.x86_64                                                                                                                    7/30 
    正在安装    : cpp-4.8.5-39.el7.x86_64                                                                                                                        8/30 
    正在安装    : trousers-0.3.14-2.el7.x86_64                                                                                                                   9/30 
    正在更新    : libgomp-4.8.5-39.el7.x86_64                                                                                                                   10/30 
    正在安装    : libmodman-2.0.1-8.el7.x86_64                                                                                                                  11/30 
    正在安装    : libproxy-0.4.11-11.el7.x86_64                                                                                                                 12/30 
    正在安装    : nettle-2.7.1-8.el7.x86_64                                                                                                                     13/30 
    正在安装    : gnutls-3.3.29-9.el7_6.x86_64                                                                                                                  14/30 
    正在安装    : mercurial-2.6.2-10.el7.x86_64                                                                                                                 15/30 
    正在安装    : pakchois-0.4-10.el7.x86_64                                                                                                                    16/30 
    正在安装    : neon-0.30.0-4.el7.x86_64                                                                                                                      17/30 
    正在安装    : subversion-libs-1.7.14-14.el7.x86_64                                                                                                          18/30 
    正在安装    : subversion-1.7.14-14.el7.x86_64                                                                                                               19/30 
    正在安装    : kernel-headers-3.10.0-1062.1.1.el7.x86_64                                                                                                     20/30 
    正在安装    : glibc-headers-2.17-292.el7.x86_64                                                                                                             21/30 
    正在安装    : glibc-devel-2.17-292.el7.x86_64                                                                                                               22/30 
    正在安装    : gcc-4.8.5-39.el7.x86_64                                                                                                                       23/30 
    正在安装    : golang-src-1.11.5-1.el7.noarch                                                                                                                24/30 
    正在安装    : golang-1.11.5-1.el7.x86_64                                                                                                                    25/30 
    正在安装    : golang-bin-1.11.5-1.el7.x86_64                                                                                                                26/30 
    清理        : libgomp-4.8.5-36.el7.x86_64                                                                                                                   27/30 
    清理        : glibc-common-2.17-260.el7.x86_64                                                                                                              28/30 
    清理        : glibc-2.17-260.el7.x86_64                                                                                                                     29/30 
    清理        : libgcc-4.8.5-36.el7.x86_64                                                                                                                    30/30 
    验证中      : trousers-0.3.14-2.el7.x86_64                                                                                                                   1/30 
    验证中      : apr-1.4.8-5.el7.x86_64                                                                                                                         2/30 
    验证中      : neon-0.30.0-4.el7.x86_64                                                                                                                       3/30 
    验证中      : gcc-4.8.5-39.el7.x86_64                                                                                                                        4/30 
    验证中      : golang-src-1.11.5-1.el7.noarch                                                                                                                 5/30 
    验证中      : subversion-1.7.14-14.el7.x86_64                                                                                                                6/30 
    验证中      : golang-1.11.5-1.el7.x86_64                                                                                                                     7/30 
    验证中      : golang-bin-1.11.5-1.el7.x86_64                                                                                                                 8/30 
    验证中      : libgomp-4.8.5-39.el7.x86_64                                                                                                                    9/30 
    验证中      : kernel-headers-3.10.0-1062.1.1.el7.x86_64                                                                                                     10/30 
    验证中      : glibc-common-2.17-292.el7.x86_64                                                                                                              11/30 
    验证中      : gnutls-3.3.29-9.el7_6.x86_64                                                                                                                  12/30 
    验证中      : libgcc-4.8.5-39.el7.x86_64                                                                                                                    13/30 
    验证中      : libmodman-2.0.1-8.el7.x86_64                                                                                                                  14/30 
    验证中      : apr-util-1.5.2-6.el7.x86_64                                                                                                                   15/30 
    验证中      : nettle-2.7.1-8.el7.x86_64                                                                                                                     16/30 
    验证中      : libmpc-1.0.1-3.el7.x86_64                                                                                                                     17/30 
    验证中      : glibc-2.17-292.el7.x86_64                                                                                                                     18/30 
    验证中      : mercurial-2.6.2-10.el7.x86_64                                                                                                                 19/30 
    验证中      : libproxy-0.4.11-11.el7.x86_64                                                                                                                 20/30 
    验证中      : glibc-devel-2.17-292.el7.x86_64                                                                                                               21/30 
    验证中      : subversion-libs-1.7.14-14.el7.x86_64                                                                                                          22/30 
    验证中      : mpfr-3.1.1-4.el7.x86_64                                                                                                                       23/30 
    验证中      : cpp-4.8.5-39.el7.x86_64                                                                                                                       24/30 
    验证中      : pakchois-0.4-10.el7.x86_64                                                                                                                    25/30 
    验证中      : glibc-headers-2.17-292.el7.x86_64                                                                                                             26/30 
    验证中      : libgcc-4.8.5-36.el7.x86_64                                                                                                                    27/30 
    验证中      : glibc-2.17-260.el7.x86_64                                                                                                                     28/30 
    验证中      : libgomp-4.8.5-36.el7.x86_64                                                                                                                   29/30 
    验证中      : glibc-common-2.17-260.el7.x86_64                                                                                                              30/30 

    已安装:
    golang.x86_64 0:1.11.5-1.el7                                                                                                                                      

    作为依赖被安装:
    apr.x86_64 0:1.4.8-5.el7             apr-util.x86_64 0:1.5.2-6.el7                  cpp.x86_64 0:4.8.5-39.el7            gcc.x86_64 0:4.8.5-39.el7                
    glibc-devel.x86_64 0:2.17-292.el7    glibc-headers.x86_64 0:2.17-292.el7            gnutls.x86_64 0:3.3.29-9.el7_6       golang-bin.x86_64 0:1.11.5-1.el7         
    golang-src.noarch 0:1.11.5-1.el7     kernel-headers.x86_64 0:3.10.0-1062.1.1.el7    libmodman.x86_64 0:2.0.1-8.el7       libmpc.x86_64 0:1.0.1-3.el7              
    libproxy.x86_64 0:0.4.11-11.el7      mercurial.x86_64 0:2.6.2-10.el7                mpfr.x86_64 0:3.1.1-4.el7            neon.x86_64 0:0.30.0-4.el7               
    nettle.x86_64 0:2.7.1-8.el7          pakchois.x86_64 0:0.4-10.el7                   subversion.x86_64 0:1.7.14-14.el7    subversion-libs.x86_64 0:1.7.14-14.el7   
    trousers.x86_64 0:0.3.14-2.el7      

    作为依赖被升级:
    glibc.x86_64 0:2.17-292.el7           glibc-common.x86_64 0:2.17-292.el7           libgcc.x86_64 0:4.8.5-39.el7           libgomp.x86_64 0:4.8.5-39.el7          

    完毕!
    [[email?protected] tmp]# go version
    go version go1.11.5 linux/amd64
    [[email?protected] tmp]# find / -name go
    /etc/alternatives/go
    /var/lib/alternatives/go
    /usr/bin/go
    /usr/lib/golang/src/cmd/go
    /usr/lib/golang/src/go
    /usr/lib/golang/bin/go
    /usr/lib/golang/pkg/linux_amd64/cmd/go
    /usr/lib/golang/pkg/linux_amd64/go
    [[email?protected] tmp]# export FALCON_HOME=/home/work
    [[email?protected] tmp]# export WORKSPACE=$FALCON_HOME/open-falcon
    [[email?protected] tmp]# mkdir -p $WORKSPACE
    [[email?protected] tmp]# rz
    rz waiting to receive.
    Starting zmodem transfer.  Press Ctrl+C to cancel.
    Transferring open-falcon-v0.3.tar.gz...
    100%   67075 KB    22358 KB/sec    00:00:03       0 Errors  

    [[email?protected] tmp]# tar xf open-falcon-v0.3.tar.gz -C $WORKSPACE
    [[email?protected] tmp]# cd $WORKSPACE
    [[email?protected] open-falcon]# ll
    总用量 4272
    drwxr-xr-x. 7 1000 1000      71 5月  30 17:11 agent
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 aggregator
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 alarm
    drwxr-xr-x. 6 1000 1000      55 5月  30 17:11 api
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 gateway
    drwxr-xr-x. 6 1000 1000      55 5月  30 17:11 graph
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 hbs
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 judge
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 nodata
    -rwxr-xr-x. 1 1000 1000 4370880 5月  30 17:11 open-falcon
    lrwxrwxrwx. 1 1000 1000      15 5月  30 17:11 plugin -> ./agent/plugin/
    lrwxrwxrwx. 1 1000 1000      15 5月  30 17:11 public -> ./agent/public/
    drwxr-xr-x. 5 1000 1000      43 5月  30 17:11 transfer
    [[email?protected] open-falcon]# cat `find ./ -type f -name "cfg.json"|egrep "alarm|api|nodata|hbs|graph|aggregator"` |grep 'root:123456[email?protected](127.0.0.1:3306)'
    [[email?protected] open-falcon]# cat `find ./ -type f -name "cfg.json"|egrep "alarm|api|nodata|hbs|graph|aggregator"` |grep 'root:@tcp(127.0.0.1:3306)'      
            "addr": "root:@tcp(127.0.0.1:3306)/falcon_portal?loc=Local&parseTime=true",
            "dsn": "root:@tcp(127.0.0.1:3306)/graph?loc=Local&parseTime=true",
        "database": "root:@tcp(127.0.0.1:3306)/falcon_portal?loc=Local&parseTime=true",
            "dsn": "root:@tcp(127.0.0.1:3306)/falcon_portal?loc=Local&parseTime=true&wait_timeout=604800",
                    "falcon_portal": "root:@tcp(127.0.0.1:3306)/falcon_portal?charset=utf8&parseTime=True&loc=Local",
                    "graph": "root:@tcp(127.0.0.1:3306)/graph?charset=utf8&parseTime=True&loc=Local",
                    "uic": "root:@tcp(127.0.0.1:3306)/uic?charset=utf8&parseTime=True&loc=Local",
                    "dashboard": "root:@tcp(127.0.0.1:3306)/dashboard?charset=utf8&parseTime=True&loc=Local",
                    "alarms": "root:@tcp(127.0.0.1:3306)/alarms?charset=utf8&parseTime=True&loc=Local",
            "addr": "root:@tcp(127.0.0.1:3306)/alarms?charset=utf8&loc=Local",
    [[email?protected] open-falcon]# ./open-falcon start
    [falcon-graph] 19882
    [falcon-hbs] 19894
    [falcon-judge] 19903
    [falcon-transfer] 19910
    [falcon-nodata] 19917
    [falcon-aggregator] 19925
    [falcon-agent] 19934
    [falcon-gateway] 19943
    [falcon-api] 19950
    [falcon-alarm] 19963
    [[email?protected] open-falcon]# ./open-falcon check
            falcon-graph         UP           19882 
            falcon-hbs         UP           19894 
            falcon-judge         UP           19903 
        falcon-transfer         UP           19910 
        falcon-nodata         UP           19917 
    falcon-aggregator         UP           19925 
            falcon-agent         UP           19934 
        falcon-gateway         UP           19943 
            falcon-api         UP           19950 
            falcon-alarm         UP           19963 
    [[email?protected] open-falcon]# ./open-falcon start agent
    [falcon-agent] 19934
    [[email?protected] open-falcon]# ./open-falcon check
            falcon-graph         UP           19882 
            falcon-hbs         UP           19894 
            falcon-judge         UP           19903 
        falcon-transfer         UP           19910 
        falcon-nodata         UP           19917 
    falcon-aggregator         UP           19925 
            falcon-agent         UP           19934 
        falcon-gateway         UP           19943 
            falcon-api         UP           19950 
            falcon-alarm         UP           19963 
    [[email?protected] open-falcon]# export HOME=/home/work
    [[email?protected] open-falcon]# export WORKSPACE=$HOME/open-falcon
    [[email?protected] open-falcon]# mkdir -p $WORKSPACE
    cd $WORKSPACE[[email?protected] open-falcon]# cd $WORKSPACE
    [[email?protected] open-falcon]# git clone https://github.com/open-falcon/dashboard.git
    正克隆到 'dashboard'...
    remote: Enumerating objects: 29, done.
    remote: Counting objects: 100% (29/29), done.
    remote: Compressing objects: 100% (26/26), done.
    remote: Total 1224 (delta 10), reused 5 (delta 3), pack-reused 1195
    接收对象中: 100% (1224/1224), 1.48 MiB | 369.00 KiB/s, done.
    处理 delta 中: 100% (669/669), done.
    [[email?protected] open-falcon]# yum install -y python-virtualenv
    yum install -y python-devel
    yum install -y openldap-devel
    yum install -y mysql-devel
    yum groupinstall "Development tools" -y已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 python-virtualenv.noarch.0.15.1.0-2.el7 将被 安装
    --> 正在处理依赖关系 python2-devel,它被软件包 python-virtualenv-15.1.0-2.el7.noarch 需要
    --> 正在检查事务
    ---> 软件包 python-devel.x86_64.0.2.7.5-86.el7 将被 安装
    --> 正在处理依赖关系 python(x86-64) = 2.7.5-86.el7,它被软件包 python-devel-2.7.5-86.el7.x86_64 需要
    --> 正在处理依赖关系 python2-rpm-macros > 3-30,它被软件包 python-devel-2.7.5-86.el7.x86_64 需要
    --> 正在处理依赖关系 python-rpm-macros > 3-30,它被软件包 python-devel-2.7.5-86.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 python.x86_64.0.2.7.5-76.el7 将被 升级
    ---> 软件包 python.x86_64.0.2.7.5-86.el7 将被 更新
    --> 正在处理依赖关系 python-libs(x86-64) = 2.7.5-86.el7,它被软件包 python-2.7.5-86.el7.x86_64 需要
    ---> 软件包 python-rpm-macros.noarch.0.3-32.el7 将被 安装
    --> 正在处理依赖关系 python-srpm-macros,它被软件包 python-rpm-macros-3-32.el7.noarch 需要
    ---> 软件包 python2-rpm-macros.noarch.0.3-32.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 python-libs.x86_64.0.2.7.5-76.el7 将被 升级
    ---> 软件包 python-libs.x86_64.0.2.7.5-86.el7 将被 更新
    ---> 软件包 python-srpm-macros.noarch.0.3-32.el7 将被 安装

    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                        架构                               版本                                      源                                大小
    ====================================================================================================================================================================
    正在安装:
    python-virtualenv                              noarch                             15.1.0-2.el7                              base                             1.7 M
    为依赖而安装:
    python-devel                                   x86_64                             2.7.5-86.el7                              base                             398 k
    python-rpm-macros                              noarch                             3-32.el7                                  base                             8.8 k
    python-srpm-macros                             noarch                             3-32.el7                                  base                             8.4 k
    python2-rpm-macros                             noarch                             3-32.el7                                  base                             7.7 k
    为依赖而更新:
    python                                         x86_64                             2.7.5-86.el7                              base                              95 k
    python-libs                                    x86_64                             2.7.5-86.el7                              base                             5.6 M

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包 (+4 依赖软件包)
    升级           ( 2 依赖软件包)

    总下载量:7.8 M
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    (1/7): python-rpm-macros-3-32.el7.noarch.rpm                                                                                                 | 8.8 kB  00:00:00     
    (2/7): python-srpm-macros-3-32.el7.noarch.rpm                                                                                                | 8.4 kB  00:00:00     
    (3/7): python2-rpm-macros-3-32.el7.noarch.rpm                                                                                                | 7.7 kB  00:00:00     
    (4/7): python-2.7.5-86.el7.x86_64.rpm                                                                                                        |  95 kB  00:00:01     
    (5/7): python-devel-2.7.5-86.el7.x86_64.rpm                                                                                                  | 398 kB  00:00:02     
    (6/7): python-virtualenv-15.1.0-2.el7.noarch.rpm                                                                                             | 1.7 MB  00:00:05     
    (7/7): python-libs-2.7.5-86.el7.x86_64.rpm                                                                                                   | 5.6 MB  00:00:19     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                410 kB/s | 7.8 MB  00:00:19     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在更新    : python-libs-2.7.5-86.el7.x86_64                                                                                                                 1/9 
    正在更新    : python-2.7.5-86.el7.x86_64                                                                                                                      2/9 
    正在安装    : python2-rpm-macros-3-32.el7.noarch                                                                                                              3/9 
    正在安装    : python-srpm-macros-3-32.el7.noarch                                                                                                              4/9 
    正在安装    : python-rpm-macros-3-32.el7.noarch                                                                                                               5/9 
    正在安装    : python-devel-2.7.5-86.el7.x86_64                                                                                                                6/9 
    正在安装    : python-virtualenv-15.1.0-2.el7.noarch                                                                                                           7/9 
    清理        : python-2.7.5-76.el7.x86_64                                                                                                                      8/9 
    清理        : python-libs-2.7.5-76.el7.x86_64                                                                                                                 9/9 
    验证中      : python-libs-2.7.5-86.el7.x86_64                                                                                                                 1/9 
    验证中      : python-devel-2.7.5-86.el7.x86_64                                                                                                                2/9 
    验证中      : python-2.7.5-86.el7.x86_64                                                                                                                      3/9 
    验证中      : python-srpm-macros-3-32.el7.noarch                                                                                                              4/9 
    验证中      : python2-rpm-macros-3-32.el7.noarch                                                                                                              5/9 
    验证中      : python-virtualenv-15.1.0-2.el7.noarch                                                                                                           6/9 
    验证中      : python-rpm-macros-3-32.el7.noarch                                                                                                               7/9 
    验证中      : python-2.7.5-76.el7.x86_64                                                                                                                      8/9 
    验证中      : python-libs-2.7.5-76.el7.x86_64                                                                                                                 9/9 

    已安装:
    python-virtualenv.noarch 0:15.1.0-2.el7                                                                                                                           

    作为依赖被安装:
    python-devel.x86_64 0:2.7.5-86.el7     python-rpm-macros.noarch 0:3-32.el7     python-srpm-macros.noarch 0:3-32.el7     python2-rpm-macros.noarch 0:3-32.el7    

    作为依赖被升级:
    python.x86_64 0:2.7.5-86.el7                                                   python-libs.x86_64 0:2.7.5-86.el7                                                  

    完毕!
    [[email?protected] open-falcon]# yum install -y python-devel
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    软件包 python-devel-2.7.5-86.el7.x86_64 已安装并且是最新版本
    无须任何处理
    [[email?protected] open-falcon]# yum install -y openldap-devel
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 openldap-devel.x86_64.0.2.4.44-21.el7_6 将被 安装
    --> 正在处理依赖关系 openldap(x86-64) = 2.4.44-21.el7_6,它被软件包 openldap-devel-2.4.44-21.el7_6.x86_64 需要
    --> 正在处理依赖关系 cyrus-sasl-devel(x86-64),它被软件包 openldap-devel-2.4.44-21.el7_6.x86_64 需要
    --> 正在检查事务
    ---> 软件包 cyrus-sasl-devel.x86_64.0.2.1.26-23.el7 将被 安装
    --> 正在处理依赖关系 cyrus-sasl(x86-64) = 2.1.26-23.el7,它被软件包 cyrus-sasl-devel-2.1.26-23.el7.x86_64 需要
    ---> 软件包 openldap.x86_64.0.2.4.44-20.el7 将被 升级
    ---> 软件包 openldap.x86_64.0.2.4.44-21.el7_6 将被 更新
    --> 正在检查事务
    ---> 软件包 cyrus-sasl.x86_64.0.2.1.26-23.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                      架构                               版本                                        源                                大小
    ====================================================================================================================================================================
    正在安装:
    openldap-devel                               x86_64                             2.4.44-21.el7_6                             base                             804 k
    为依赖而安装:
    cyrus-sasl                                   x86_64                             2.1.26-23.el7                               base                              88 k
    cyrus-sasl-devel                             x86_64                             2.1.26-23.el7                               base                             310 k
    为依赖而更新:
    openldap                                     x86_64                             2.4.44-21.el7_6                             base                             356 k

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包 (+2 依赖软件包)
    升级           ( 1 依赖软件包)

    总下载量:1.5 M
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    (1/4): cyrus-sasl-2.1.26-23.el7.x86_64.rpm                                                                                                   |  88 kB  00:00:00     
    (2/4): cyrus-sasl-devel-2.1.26-23.el7.x86_64.rpm                                                                                             | 310 kB  00:00:02     
    (3/4): openldap-2.4.44-21.el7_6.x86_64.rpm                                                                                                   | 356 kB  00:00:03     
    (4/4): openldap-devel-2.4.44-21.el7_6.x86_64.rpm                                                                                             | 804 kB  00:00:04     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                359 kB/s | 1.5 MB  00:00:04     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在更新    : openldap-2.4.44-21.el7_6.x86_64                                                                                                                 1/5 
    正在安装    : cyrus-sasl-2.1.26-23.el7.x86_64                                                                                                                 2/5 
    正在安装    : cyrus-sasl-devel-2.1.26-23.el7.x86_64                                                                                                           3/5 
    正在安装    : openldap-devel-2.4.44-21.el7_6.x86_64                                                                                                           4/5 
    清理        : openldap-2.4.44-20.el7.x86_64                                                                                                                   5/5 
    验证中      : cyrus-sasl-2.1.26-23.el7.x86_64                                                                                                                 1/5 
    验证中      : openldap-2.4.44-21.el7_6.x86_64                                                                                                                 2/5 
    验证中      : openldap-devel-2.4.44-21.el7_6.x86_64                                                                                                           3/5 
    验证中      : cyrus-sasl-devel-2.1.26-23.el7.x86_64                                                                                                           4/5 
    验证中      : openldap-2.4.44-20.el7.x86_64                                                                                                                   5/5 

    已安装:
    openldap-devel.x86_64 0:2.4.44-21.el7_6                                                                                                                           

    作为依赖被安装:
    cyrus-sasl.x86_64 0:2.1.26-23.el7                                             cyrus-sasl-devel.x86_64 0:2.1.26-23.el7                                            

    作为依赖被升级:
    openldap.x86_64 0:2.4.44-21.el7_6                                                                                                                                 

    完毕!
    [[email?protected] open-falcon]# yum install -y mysql-devel
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 mariadb-devel.x86_64.1.5.5.64-1.el7 将被 安装
    --> 正在处理依赖关系 openssl-devel(x86-64),它被软件包 1:mariadb-devel-5.5.64-1.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 openssl-devel.x86_64.1.1.0.2k-19.el7 将被 安装
    --> 正在处理依赖关系 openssl-libs(x86-64) = 1:1.0.2k-19.el7,它被软件包 1:openssl-devel-1.0.2k-19.el7.x86_64 需要
    --> 正在处理依赖关系 zlib-devel(x86-64),它被软件包 1:openssl-devel-1.0.2k-19.el7.x86_64 需要
    --> 正在处理依赖关系 krb5-devel(x86-64),它被软件包 1:openssl-devel-1.0.2k-19.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 krb5-devel.x86_64.0.1.15.1-37.el7_7.2 将被 安装
    --> 正在处理依赖关系 libkadm5(x86-64) = 1.15.1-37.el7_7.2,它被软件包 krb5-devel-1.15.1-37.el7_7.2.x86_64 需要
    --> 正在处理依赖关系 krb5-libs(x86-64) = 1.15.1-37.el7_7.2,它被软件包 krb5-devel-1.15.1-37.el7_7.2.x86_64 需要
    --> 正在处理依赖关系 libverto-devel,它被软件包 krb5-devel-1.15.1-37.el7_7.2.x86_64 需要
    --> 正在处理依赖关系 libselinux-devel,它被软件包 krb5-devel-1.15.1-37.el7_7.2.x86_64 需要
    --> 正在处理依赖关系 libcom_err-devel,它被软件包 krb5-devel-1.15.1-37.el7_7.2.x86_64 需要
    --> 正在处理依赖关系 keyutils-libs-devel,它被软件包 krb5-devel-1.15.1-37.el7_7.2.x86_64 需要
    ---> 软件包 openssl-libs.x86_64.1.1.0.2k-16.el7 将被 升级
    --> 正在处理依赖关系 openssl-libs(x86-64) = 1:1.0.2k-16.el7,它被软件包 1:openssl-1.0.2k-16.el7.x86_64 需要
    ---> 软件包 openssl-libs.x86_64.1.1.0.2k-19.el7 将被 更新
    ---> 软件包 zlib-devel.x86_64.0.1.2.7-18.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 keyutils-libs-devel.x86_64.0.1.5.8-3.el7 将被 安装
    ---> 软件包 krb5-libs.x86_64.0.1.15.1-34.el7 将被 升级
    ---> 软件包 krb5-libs.x86_64.0.1.15.1-37.el7_7.2 将被 更新
    ---> 软件包 libcom_err-devel.x86_64.0.1.42.9-16.el7 将被 安装
    --> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-16.el7,它被软件包 libcom_err-devel-1.42.9-16.el7.x86_64 需要
    ---> 软件包 libkadm5.x86_64.0.1.15.1-37.el7_7.2 将被 安装
    ---> 软件包 libselinux-devel.x86_64.0.2.5-14.1.el7 将被 安装
    --> 正在处理依赖关系 libsepol-devel(x86-64) >= 2.5-10,它被软件包 libselinux-devel-2.5-14.1.el7.x86_64 需要
    --> 正在处理依赖关系 pkgconfig(libsepol),它被软件包 libselinux-devel-2.5-14.1.el7.x86_64 需要
    --> 正在处理依赖关系 pkgconfig(libpcre),它被软件包 libselinux-devel-2.5-14.1.el7.x86_64 需要
    ---> 软件包 libverto-devel.x86_64.0.0.2.5-4.el7 将被 安装
    ---> 软件包 openssl.x86_64.1.1.0.2k-16.el7 将被 升级
    ---> 软件包 openssl.x86_64.1.1.0.2k-19.el7 将被 更新
    --> 正在检查事务
    ---> 软件包 libcom_err.x86_64.0.1.42.9-13.el7 将被 升级
    --> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-13.el7,它被软件包 e2fsprogs-1.42.9-13.el7.x86_64 需要
    --> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-13.el7,它被软件包 e2fsprogs-libs-1.42.9-13.el7.x86_64 需要
    --> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-13.el7,它被软件包 libss-1.42.9-13.el7.x86_64 需要
    ---> 软件包 libcom_err.x86_64.0.1.42.9-16.el7 将被 更新
    ---> 软件包 libsepol-devel.x86_64.0.2.5-10.el7 将被 安装
    ---> 软件包 pcre-devel.x86_64.0.8.32-17.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 e2fsprogs.x86_64.0.1.42.9-13.el7 将被 升级
    ---> 软件包 e2fsprogs.x86_64.0.1.42.9-16.el7 将被 更新
    ---> 软件包 e2fsprogs-libs.x86_64.0.1.42.9-13.el7 将被 升级
    ---> 软件包 e2fsprogs-libs.x86_64.0.1.42.9-16.el7 将被 更新
    ---> 软件包 libss.x86_64.0.1.42.9-13.el7 将被 升级
    ---> 软件包 libss.x86_64.0.1.42.9-16.el7 将被 更新
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                       架构                             版本                                        源                                 大小
    ====================================================================================================================================================================
    正在安装:
    mariadb-devel                                 x86_64                           1:5.5.64-1.el7                              base                              755 k
    为依赖而安装:
    keyutils-libs-devel                           x86_64                           1.5.8-3.el7                                 base                               37 k
    krb5-devel                                    x86_64                           1.15.1-37.el7_7.2                           updates                           272 k
    libcom_err-devel                              x86_64                           1.42.9-16.el7                               base                               32 k
    libkadm5                                      x86_64                           1.15.1-37.el7_7.2                           updates                           178 k
    libselinux-devel                              x86_64                           2.5-14.1.el7                                base                              187 k
    libsepol-devel                                x86_64                           2.5-10.el7                                  base                               77 k
    libverto-devel                                x86_64                           0.2.5-4.el7                                 base                               12 k
    openssl-devel                                 x86_64                           1:1.0.2k-19.el7                             base                              1.5 M
    pcre-devel                                    x86_64                           8.32-17.el7                                 base                              480 k
    zlib-devel                                    x86_64                           1.2.7-18.el7                                base                               50 k
    为依赖而更新:
    e2fsprogs                                     x86_64                           1.42.9-16.el7                               base                              700 k
    e2fsprogs-libs                                x86_64                           1.42.9-16.el7                               base                              167 k
    krb5-libs                                     x86_64                           1.15.1-37.el7_7.2                           updates                           805 k
    libcom_err                                    x86_64                           1.42.9-16.el7                               base                               41 k
    libss                                         x86_64                           1.42.9-16.el7                               base                               46 k
    openssl                                       x86_64                           1:1.0.2k-19.el7                             base                              493 k
    openssl-libs                                  x86_64                           1:1.0.2k-19.el7                             base                              1.2 M

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包 (+10 依赖软件包)
    升级           (  7 依赖软件包)

    总下载量:6.9 M
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    (1/18): keyutils-libs-devel-1.5.8-3.el7.x86_64.rpm                                                                                           |  37 kB  00:00:00     
    (2/18): libcom_err-1.42.9-16.el7.x86_64.rpm                                                                                                  |  41 kB  00:00:00     
    (3/18): libcom_err-devel-1.42.9-16.el7.x86_64.rpm                                                                                            |  32 kB  00:00:00     
    (4/18): e2fsprogs-libs-1.42.9-16.el7.x86_64.rpm                                                                                              | 167 kB  00:00:01     
    (5/18): libkadm5-1.15.1-37.el7_7.2.x86_64.rpm                                                                                                | 178 kB  00:00:01     
    (6/18): libselinux-devel-2.5-14.1.el7.x86_64.rpm                                                                                             | 187 kB  00:00:01     
    (7/18): libss-1.42.9-16.el7.x86_64.rpm                                                                                                       |  46 kB  00:00:00     
    (8/18): libsepol-devel-2.5-10.el7.x86_64.rpm                                                                                                 |  77 kB  00:00:00     
    (9/18): libverto-devel-0.2.5-4.el7.x86_64.rpm                                                                                                |  12 kB  00:00:00     
    (10/18): e2fsprogs-1.42.9-16.el7.x86_64.rpm                                                                                                  | 700 kB  00:00:05     
    (11/18): krb5-devel-1.15.1-37.el7_7.2.x86_64.rpm                                                                                             | 272 kB  00:00:07     
    (12/18): openssl-1.0.2k-19.el7.x86_64.rpm                                                                                                    | 493 kB  00:00:04     
    (13/18): krb5-libs-1.15.1-37.el7_7.2.x86_64.rpm                                                                                              | 805 kB  00:00:09     
    (14/18): mariadb-devel-5.5.64-1.el7.x86_64.rpm                                                                                               | 755 kB  00:00:06     
    (15/18): pcre-devel-8.32-17.el7.x86_64.rpm                                                                                                   | 480 kB  00:00:03     
    (16/18): openssl-libs-1.0.2k-19.el7.x86_64.rpm                                                                                               | 1.2 MB  00:00:06     
    (17/18): zlib-devel-1.2.7-18.el7.x86_64.rpm                                                                                                  |  50 kB  00:00:05     
    (18/18): openssl-devel-1.0.2k-19.el7.x86_64.rpm                                                                                              | 1.5 MB  00:00:10     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                447 kB/s | 6.9 MB  00:00:15     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在更新    : libcom_err-1.42.9-16.el7.x86_64                                                                                                                1/25 
    正在更新    : krb5-libs-1.15.1-37.el7_7.2.x86_64                                                                                                             2/25 
    正在更新    : 1:openssl-libs-1.0.2k-19.el7.x86_64                                                                                                            3/25 
    正在安装    : libkadm5-1.15.1-37.el7_7.2.x86_64                                                                                                              4/25 
    正在安装    : libcom_err-devel-1.42.9-16.el7.x86_64                                                                                                          5/25 
    正在更新    : libss-1.42.9-16.el7.x86_64                                                                                                                     6/25 
    正在更新    : e2fsprogs-libs-1.42.9-16.el7.x86_64                                                                                                            7/25 
    正在安装    : libsepol-devel-2.5-10.el7.x86_64                                                                                                               8/25 
    正在安装    : zlib-devel-1.2.7-18.el7.x86_64                                                                                                                 9/25 
    正在安装    : libverto-devel-0.2.5-4.el7.x86_64                                                                                                             10/25 
    正在安装    : pcre-devel-8.32-17.el7.x86_64                                                                                                                 11/25 
    正在安装    : libselinux-devel-2.5-14.1.el7.x86_64                                                                                                          12/25 
    正在安装    : keyutils-libs-devel-1.5.8-3.el7.x86_64                                                                                                        13/25 
    正在安装    : krb5-devel-1.15.1-37.el7_7.2.x86_64                                                                                                           14/25 
    正在安装    : 1:openssl-devel-1.0.2k-19.el7.x86_64                                                                                                          15/25 
    正在安装    : 1:mariadb-devel-5.5.64-1.el7.x86_64                                                                                                           16/25 
    正在更新    : e2fsprogs-1.42.9-16.el7.x86_64                                                                                                                17/25 
    正在更新    : 1:openssl-1.0.2k-19.el7.x86_64                                                                                                                18/25 
    清理        : 1:openssl-1.0.2k-16.el7.x86_64                                                                                                                19/25 
    清理        : e2fsprogs-1.42.9-13.el7.x86_64                                                                                                                20/25 
    清理        : krb5-libs-1.15.1-34.el7.x86_64                                                                                                                21/25 
    清理        : 1:openssl-libs-1.0.2k-16.el7.x86_64                                                                                                           22/25 
    清理        : e2fsprogs-libs-1.42.9-13.el7.x86_64                                                                                                           23/25 
    清理        : libss-1.42.9-13.el7.x86_64                                                                                                                    24/25 
    清理        : libcom_err-1.42.9-13.el7.x86_64                                                                                                               25/25 
    验证中      : keyutils-libs-devel-1.5.8-3.el7.x86_64                                                                                                         1/25 
    验证中      : krb5-devel-1.15.1-37.el7_7.2.x86_64                                                                                                            2/25 
    验证中      : libcom_err-devel-1.42.9-16.el7.x86_64                                                                                                          3/25 
    验证中      : pcre-devel-8.32-17.el7.x86_64                                                                                                                  4/25 
    验证中      : 1:openssl-libs-1.0.2k-19.el7.x86_64                                                                                                            5/25 
    验证中      : libverto-devel-0.2.5-4.el7.x86_64                                                                                                              6/25 
    验证中      : 1:mariadb-devel-5.5.64-1.el7.x86_64                                                                                                            7/25 
    验证中      : zlib-devel-1.2.7-18.el7.x86_64                                                                                                                 8/25 
    验证中      : e2fsprogs-1.42.9-16.el7.x86_64                                                                                                                 9/25 
    验证中      : krb5-libs-1.15.1-37.el7_7.2.x86_64                                                                                                            10/25 
    验证中      : libss-1.42.9-16.el7.x86_64                                                                                                                    11/25 
    验证中      : 1:openssl-1.0.2k-19.el7.x86_64                                                                                                                12/25 
    验证中      : 1:openssl-devel-1.0.2k-19.el7.x86_64                                                                                                          13/25 
    验证中      : libcom_err-1.42.9-16.el7.x86_64                                                                                                               14/25 
    验证中      : libsepol-devel-2.5-10.el7.x86_64                                                                                                              15/25 
    验证中      : e2fsprogs-libs-1.42.9-16.el7.x86_64                                                                                                           16/25 
    验证中      : libkadm5-1.15.1-37.el7_7.2.x86_64                                                                                                             17/25 
    验证中      : libselinux-devel-2.5-14.1.el7.x86_64                                                                                                          18/25 
    验证中      : 1:openssl-libs-1.0.2k-16.el7.x86_64                                                                                                           19/25 
    验证中      : 1:openssl-1.0.2k-16.el7.x86_64                                                                                                                20/25 
    验证中      : libss-1.42.9-13.el7.x86_64                                                                                                                    21/25 
    验证中      : e2fsprogs-libs-1.42.9-13.el7.x86_64                                                                                                           22/25 
    验证中      : krb5-libs-1.15.1-34.el7.x86_64                                                                                                                23/25 
    验证中      : libcom_err-1.42.9-13.el7.x86_64                                                                                                               24/25 
    验证中      : e2fsprogs-1.42.9-13.el7.x86_64                                                                                                                25/25 

    已安装:
    mariadb-devel.x86_64 1:5.5.64-1.el7                                                                                                                               

    作为依赖被安装:
    keyutils-libs-devel.x86_64 0:1.5.8-3.el7  krb5-devel.x86_64 0:1.15.1-37.el7_7.2  libcom_err-devel.x86_64 0:1.42.9-16.el7  libkadm5.x86_64 0:1.15.1-37.el7_7.2  
    libselinux-devel.x86_64 0:2.5-14.1.el7    libsepol-devel.x86_64 0:2.5-10.el7     libverto-devel.x86_64 0:0.2.5-4.el7      openssl-devel.x86_64 1:1.0.2k-19.el7 
    pcre-devel.x86_64 0:8.32-17.el7           zlib-devel.x86_64 0:1.2.7-18.el7      

    作为依赖被升级:
    e2fsprogs.x86_64 0:1.42.9-16.el7      e2fsprogs-libs.x86_64 0:1.42.9-16.el7      krb5-libs.x86_64 0:1.15.1-37.el7_7.2      libcom_err.x86_64 0:1.42.9-16.el7     
    libss.x86_64 0:1.42.9-16.el7          openssl.x86_64 1:1.0.2k-19.el7             openssl-libs.x86_64 1:1.0.2k-19.el7      

    完毕!
    [[email?protected] open-falcon]# yum groupinstall "Development tools" -y
    已加载插件:fastestmirror
    没有安装组信息文件
    Maybe run: yum groups mark convert (see man yum)
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 autoconf.noarch.0.2.69-11.el7 将被 安装
    --> 正在处理依赖关系 m4 >= 1.4.14,它被软件包 autoconf-2.69-11.el7.noarch 需要
    ---> 软件包 automake.noarch.0.1.13.4-3.el7 将被 安装
    --> 正在处理依赖关系 perl(Thread::Queue),它被软件包 automake-1.13.4-3.el7.noarch 需要
    --> 正在处理依赖关系 perl(TAP::Parser),它被软件包 automake-1.13.4-3.el7.noarch 需要
    ---> 软件包 bison.x86_64.0.3.0.4-2.el7 将被 安装
    ---> 软件包 byacc.x86_64.0.1.9.20130304-3.el7 将被 安装
    ---> 软件包 cscope.x86_64.0.15.8-10.el7 将被 安装
    --> 正在处理依赖关系 emacs-filesystem,它被软件包 cscope-15.8-10.el7.x86_64 需要
    ---> 软件包 ctags.x86_64.0.5.8-13.el7 将被 安装
    ---> 软件包 diffstat.x86_64.0.1.57-4.el7 将被 安装
    ---> 软件包 doxygen.x86_64.1.1.8.5-3.el7 将被 安装
    ---> 软件包 elfutils.x86_64.0.0.176-2.el7 将被 安装
    --> 正在处理依赖关系 elfutils-libs(x86-64) = 0.176-2.el7,它被软件包 elfutils-0.176-2.el7.x86_64 需要
    --> 正在处理依赖关系 elfutils-libelf(x86-64) = 0.176-2.el7,它被软件包 elfutils-0.176-2.el7.x86_64 需要
    --> 正在处理依赖关系 libdw.so.1(ELFUTILS_0.175)(64bit),它被软件包 elfutils-0.176-2.el7.x86_64 需要
    --> 正在处理依赖关系 libdw.so.1(ELFUTILS_0.173)(64bit),它被软件包 elfutils-0.176-2.el7.x86_64 需要
    ---> 软件包 flex.x86_64.0.2.5.37-6.el7 将被 安装
    ---> 软件包 gcc-c++.x86_64.0.4.8.5-39.el7 将被 安装
    --> 正在处理依赖关系 libstdc++-devel = 4.8.5-39.el7,它被软件包 gcc-c++-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libstdc++ = 4.8.5-39.el7,它被软件包 gcc-c++-4.8.5-39.el7.x86_64 需要
    ---> 软件包 gcc-gfortran.x86_64.0.4.8.5-39.el7 将被 安装
    --> 正在处理依赖关系 libquadmath-devel = 4.8.5-39.el7,它被软件包 gcc-gfortran-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libquadmath = 4.8.5-39.el7,它被软件包 gcc-gfortran-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libgfortran = 4.8.5-39.el7,它被软件包 gcc-gfortran-4.8.5-39.el7.x86_64 需要
    --> 正在处理依赖关系 libgfortran.so.3()(64bit),它被软件包 gcc-gfortran-4.8.5-39.el7.x86_64 需要
    ---> 软件包 indent.x86_64.0.2.2.11-13.el7 将被 安装
    ---> 软件包 intltool.noarch.0.0.50.2-7.el7 将被 安装
    --> 正在处理依赖关系 perl(XML::Parser),它被软件包 intltool-0.50.2-7.el7.noarch 需要
    --> 正在处理依赖关系 gettext-devel,它被软件包 intltool-0.50.2-7.el7.noarch 需要
    ---> 软件包 libtool.x86_64.0.2.4.2-22.el7_3 将被 安装
    ---> 软件包 patch.x86_64.0.2.7.1-11.el7 将被 安装
    ---> 软件包 patchutils.x86_64.0.0.3.3-4.el7 将被 安装
    ---> 软件包 rcs.x86_64.0.5.9.0-5.el7 将被 安装
    ---> 软件包 redhat-rpm-config.noarch.0.9.1.0-88.el7.centos 将被 安装
    --> 正在处理依赖关系 dwz >= 0.4,它被软件包 redhat-rpm-config-9.1.0-88.el7.centos.noarch 需要
    --> 正在处理依赖关系 zip,它被软件包 redhat-rpm-config-9.1.0-88.el7.centos.noarch 需要
    --> 正在处理依赖关系 perl-srpm-macros,它被软件包 redhat-rpm-config-9.1.0-88.el7.centos.noarch 需要
    ---> 软件包 rpm-build.x86_64.0.4.11.3-40.el7 将被 安装
    --> 正在处理依赖关系 rpm = 4.11.3-40.el7,它被软件包 rpm-build-4.11.3-40.el7.x86_64 需要
    --> 正在处理依赖关系 unzip,它被软件包 rpm-build-4.11.3-40.el7.x86_64 需要
    --> 正在处理依赖关系 bzip2,它被软件包 rpm-build-4.11.3-40.el7.x86_64 需要
    --> 正在处理依赖关系 /usr/bin/gdb-add-index,它被软件包 rpm-build-4.11.3-40.el7.x86_64 需要
    ---> 软件包 rpm-sign.x86_64.0.4.11.3-40.el7 将被 安装
    --> 正在处理依赖关系 rpm-build-libs(x86-64) = 4.11.3-40.el7,它被软件包 rpm-sign-4.11.3-40.el7.x86_64 需要
    ---> 软件包 swig.x86_64.0.2.0.10-5.el7 将被 安装
    ---> 软件包 systemtap.x86_64.0.4.0-9.el7 将被 安装
    --> 正在处理依赖关系 systemtap-devel = 4.0-9.el7,它被软件包 systemtap-4.0-9.el7.x86_64 需要
    --> 正在处理依赖关系 systemtap-client = 4.0-9.el7,它被软件包 systemtap-4.0-9.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 bzip2.x86_64.0.1.0.6-13.el7 将被 安装
    ---> 软件包 dwz.x86_64.0.0.11-3.el7 将被 安装
    ---> 软件包 elfutils-libelf.x86_64.0.0.172-2.el7 将被 升级
    ---> 软件包 elfutils-libelf.x86_64.0.0.176-2.el7 将被 更新
    ---> 软件包 elfutils-libs.x86_64.0.0.172-2.el7 将被 升级
    ---> 软件包 elfutils-libs.x86_64.0.0.176-2.el7 将被 更新
    ---> 软件包 emacs-filesystem.noarch.1.24.3-22.el7 将被 安装
    ---> 软件包 gdb.x86_64.0.7.6.1-115.el7 将被 安装
    ---> 软件包 gettext-devel.x86_64.0.0.19.8.1-2.el7 将被 安装
    --> 正在处理依赖关系 gettext-common-devel = 0.19.8.1-2.el7,它被软件包 gettext-devel-0.19.8.1-2.el7.x86_64 需要
    ---> 软件包 libgfortran.x86_64.0.4.8.5-39.el7 将被 安装
    ---> 软件包 libquadmath.x86_64.0.4.8.5-39.el7 将被 安装
    ---> 软件包 libquadmath-devel.x86_64.0.4.8.5-39.el7 将被 安装
    ---> 软件包 libstdc++.x86_64.0.4.8.5-36.el7 将被 升级
    ---> 软件包 libstdc++.x86_64.0.4.8.5-39.el7 将被 更新
    ---> 软件包 libstdc++-devel.x86_64.0.4.8.5-39.el7 将被 安装
    ---> 软件包 m4.x86_64.0.1.4.16-10.el7 将被 安装
    ---> 软件包 perl-Test-Harness.noarch.0.3.28-3.el7 将被 安装
    ---> 软件包 perl-Thread-Queue.noarch.0.3.02-2.el7 将被 安装
    ---> 软件包 perl-XML-Parser.x86_64.0.2.41-10.el7 将被 安装
    ---> 软件包 perl-srpm-macros.noarch.0.1-8.el7 将被 安装
    ---> 软件包 rpm.x86_64.0.4.11.3-35.el7 将被 升级
    --> 正在处理依赖关系 rpm = 4.11.3-35.el7,它被软件包 rpm-python-4.11.3-35.el7.x86_64 需要
    --> 正在处理依赖关系 rpm = 4.11.3-35.el7,它被软件包 rpm-libs-4.11.3-35.el7.x86_64 需要
    ---> 软件包 rpm.x86_64.0.4.11.3-40.el7 将被 更新
    ---> 软件包 rpm-build-libs.x86_64.0.4.11.3-35.el7 将被 升级
    ---> 软件包 rpm-build-libs.x86_64.0.4.11.3-40.el7 将被 更新
    ---> 软件包 systemtap-client.x86_64.0.4.0-9.el7 将被 安装
    --> 正在处理依赖关系 systemtap-runtime = 4.0-9.el7,它被软件包 systemtap-client-4.0-9.el7.x86_64 需要
    --> 正在处理依赖关系 mokutil,它被软件包 systemtap-client-4.0-9.el7.x86_64 需要
    --> 正在处理依赖关系 libavahi-common.so.3()(64bit),它被软件包 systemtap-client-4.0-9.el7.x86_64 需要
    --> 正在处理依赖关系 libavahi-client.so.3()(64bit),它被软件包 systemtap-client-4.0-9.el7.x86_64 需要
    ---> 软件包 systemtap-devel.x86_64.0.4.0-9.el7 将被 安装
    --> 正在处理依赖关系 kernel-devel-uname-r,它被软件包 systemtap-devel-4.0-9.el7.x86_64 需要
    ---> 软件包 unzip.x86_64.0.6.0-20.el7 将被 安装
    ---> 软件包 zip.x86_64.0.3.0-11.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 avahi-libs.x86_64.0.0.6.31-19.el7 将被 安装
    ---> 软件包 gettext-common-devel.noarch.0.0.19.8.1-2.el7 将被 安装
    ---> 软件包 kernel-debug-devel.x86_64.0.3.10.0-1062.1.1.el7 将被 安装
    ---> 软件包 mokutil.x86_64.0.15-2.el7.centos 将被 安装
    --> 正在处理依赖关系 libefivar.so.1(libefivar.so.0)(64bit),它被软件包 mokutil-15-2.el7.centos.x86_64 需要
    --> 正在处理依赖关系 libefivar.so.1(LIBEFIVAR_0.24)(64bit),它被软件包 mokutil-15-2.el7.centos.x86_64 需要
    --> 正在处理依赖关系 libefivar.so.1()(64bit),它被软件包 mokutil-15-2.el7.centos.x86_64 需要
    ---> 软件包 rpm-libs.x86_64.0.4.11.3-35.el7 将被 升级
    ---> 软件包 rpm-libs.x86_64.0.4.11.3-40.el7 将被 更新
    ---> 软件包 rpm-python.x86_64.0.4.11.3-35.el7 将被 升级
    ---> 软件包 rpm-python.x86_64.0.4.11.3-40.el7 将被 更新
    ---> 软件包 systemtap-runtime.x86_64.0.4.0-9.el7 将被 安装
    --> 正在处理依赖关系 libsymtabAPI.so.9.3()(64bit),它被软件包 systemtap-runtime-4.0-9.el7.x86_64 需要
    --> 正在处理依赖关系 libdyninstAPI.so.9.3()(64bit),它被软件包 systemtap-runtime-4.0-9.el7.x86_64 需要
    --> 正在检查事务
    ---> 软件包 dyninst.x86_64.0.9.3.1-3.el7 将被 安装
    --> 正在处理依赖关系 libdwarf.so.0()(64bit),它被软件包 dyninst-9.3.1-3.el7.x86_64 需要
    --> 正在处理依赖关系 libboost_thread-mt.so.1.53.0()(64bit),它被软件包 dyninst-9.3.1-3.el7.x86_64 需要
    --> 正在处理依赖关系 libboost_system-mt.so.1.53.0()(64bit),它被软件包 dyninst-9.3.1-3.el7.x86_64 需要
    --> 正在处理依赖关系 libboost_date_time-mt.so.1.53.0()(64bit),它被软件包 dyninst-9.3.1-3.el7.x86_64 需要
    ---> 软件包 efivar-libs.x86_64.0.36-12.el7 将被 安装
    --> 正在检查事务
    ---> 软件包 boost-date-time.x86_64.0.1.53.0-27.el7 将被 安装
    ---> 软件包 boost-system.x86_64.0.1.53.0-27.el7 将被 安装
    ---> 软件包 boost-thread.x86_64.0.1.53.0-27.el7 将被 安装
    ---> 软件包 libdwarf.x86_64.0.20130207-4.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                       架构                            版本                                          源                                大小
    ====================================================================================================================================================================
    Installing for group install "开发工具":
    autoconf                                      noarch                          2.69-11.el7                                   base                             701 k
    automake                                      noarch                          1.13.4-3.el7                                  base                             679 k
    bison                                         x86_64                          3.0.4-2.el7                                   base                             674 k
    byacc                                         x86_64                          1.9.20130304-3.el7                            base                              65 k
    cscope                                        x86_64                          15.8-10.el7                                   base                             203 k
    ctags                                         x86_64                          5.8-13.el7                                    base                             155 k
    diffstat                                      x86_64                          1.57-4.el7                                    base                              35 k
    doxygen                                       x86_64                          1:1.8.5-3.el7                                 base                             3.6 M
    elfutils                                      x86_64                          0.176-2.el7                                   base                             305 k
    flex                                          x86_64                          2.5.37-6.el7                                  base                             293 k
    gcc-c++                                       x86_64                          4.8.5-39.el7                                  base                             7.2 M
    gcc-gfortran                                  x86_64                          4.8.5-39.el7                                  base                             6.7 M
    indent                                        x86_64                          2.2.11-13.el7                                 base                             150 k
    intltool                                      noarch                          0.50.2-7.el7                                  base                              59 k
    libtool                                       x86_64                          2.4.2-22.el7_3                                base                             588 k
    patch                                         x86_64                          2.7.1-11.el7                                  base                             110 k
    patchutils                                    x86_64                          0.3.3-4.el7                                   base                             104 k
    rcs                                           x86_64                          5.9.0-5.el7                                   base                             230 k
    redhat-rpm-config                             noarch                          9.1.0-88.el7.centos                           base                              81 k
    rpm-build                                     x86_64                          4.11.3-40.el7                                 base                             149 k
    rpm-sign                                      x86_64                          4.11.3-40.el7                                 base                              48 k
    swig                                          x86_64                          2.0.10-5.el7                                  base                             1.3 M
    systemtap                                     x86_64                          4.0-9.el7                                     base                              15 k
    为依赖而安装:
    avahi-libs                                    x86_64                          0.6.31-19.el7                                 base                              61 k
    boost-date-time                               x86_64                          1.53.0-27.el7                                 base                              52 k
    boost-system                                  x86_64                          1.53.0-27.el7                                 base                              40 k
    boost-thread                                  x86_64                          1.53.0-27.el7                                 base                              57 k
    bzip2                                         x86_64                          1.0.6-13.el7                                  base                              52 k
    dwz                                           x86_64                          0.11-3.el7                                    base                              99 k
    dyninst                                       x86_64                          9.3.1-3.el7                                   base                             3.5 M
    efivar-libs                                   x86_64                          36-12.el7                                     base                              88 k
    emacs-filesystem                              noarch                          1:24.3-22.el7                                 base                              58 k
    gdb                                           x86_64                          7.6.1-115.el7                                 base                             2.4 M
    gettext-common-devel                          noarch                          0.19.8.1-2.el7                                base                             410 k
    gettext-devel                                 x86_64                          0.19.8.1-2.el7                                base                             320 k
    kernel-debug-devel                            x86_64                          3.10.0-1062.1.1.el7                           updates                           18 M
    libdwarf                                      x86_64                          20130207-4.el7                                base                             109 k
    libgfortran                                   x86_64                          4.8.5-39.el7                                  base                             300 k
    libquadmath                                   x86_64                          4.8.5-39.el7                                  base                             190 k
    libquadmath-devel                             x86_64                          4.8.5-39.el7                                  base                              53 k
    libstdc++-devel                               x86_64                          4.8.5-39.el7                                  base                             1.5 M
    m4                                            x86_64                          1.4.16-10.el7                                 base                             256 k
    mokutil                                       x86_64                          15-2.el7.centos                               base                              42 k
    perl-Test-Harness                             noarch                          3.28-3.el7                                    base                             302 k
    perl-Thread-Queue                             noarch                          3.02-2.el7                                    base                              17 k
    perl-XML-Parser                               x86_64                          2.41-10.el7                                   base                             223 k
    perl-srpm-macros                              noarch                          1-8.el7                                       base                             4.6 k
    systemtap-client                              x86_64                          4.0-9.el7                                     base                             3.6 M
    systemtap-devel                               x86_64                          4.0-9.el7                                     base                             2.2 M
    systemtap-runtime                             x86_64                          4.0-9.el7                                     base                             443 k
    unzip                                         x86_64                          6.0-20.el7                                    base                             170 k
    zip                                           x86_64                          3.0-11.el7                                    base                             260 k
    为依赖而更新:
    elfutils-libelf                               x86_64                          0.176-2.el7                                   base                             194 k
    elfutils-libs                                 x86_64                          0.176-2.el7                                   base                             291 k
    libstdc++                                     x86_64                          4.8.5-39.el7                                  base                             305 k
    rpm                                           x86_64                          4.11.3-40.el7                                 base                             1.2 M
    rpm-build-libs                                x86_64                          4.11.3-40.el7                                 base                             107 k
    rpm-libs                                      x86_64                          4.11.3-40.el7                                 base                             278 k
    rpm-python                                    x86_64                          4.11.3-40.el7                                 base                              83 k

    事务概要
    ====================================================================================================================================================================
    安装  23 软件包 (+29 依赖软件包)
    升级            (  7 依赖软件包)

    总下载量:60 M
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    (1/59): boost-date-time-1.53.0-27.el7.x86_64.rpm                                                                                             |  52 kB  00:00:02     
    (2/59): avahi-libs-0.6.31-19.el7.x86_64.rpm                                                                                                  |  61 kB  00:00:02     
    (3/59): boost-system-1.53.0-27.el7.x86_64.rpm                                                                                                |  40 kB  00:00:00     
    (4/59): boost-thread-1.53.0-27.el7.x86_64.rpm                                                                                                |  57 kB  00:00:02     
    (5/59): bzip2-1.0.6-13.el7.x86_64.rpm                                                                                                        |  52 kB  00:00:00     
    (6/59): bison-3.0.4-2.el7.x86_64.rpm                                                                                                         | 674 kB  00:00:05     
    (7/59): automake-1.13.4-3.el7.noarch.rpm                                                                                                     | 679 kB  00:00:05     
    (8/59): byacc-1.9.20130304-3.el7.x86_64.rpm                                                                                                  |  65 kB  00:00:02     
    (9/59): diffstat-1.57-4.el7.x86_64.rpm                                                                                                       |  35 kB  00:00:00     
    (10/59): dwz-0.11-3.el7.x86_64.rpm                                                                                                           |  99 kB  00:00:00     
    (11/59): ctags-5.8-13.el7.x86_64.rpm                                                                                                         | 155 kB  00:00:01     
    (12/59): cscope-15.8-10.el7.x86_64.rpm                                                                                                       | 203 kB  00:00:01     
    (13/59): autoconf-2.69-11.el7.noarch.rpm                                                                                                     | 701 kB  00:00:07     
    (14/59): efivar-libs-36-12.el7.x86_64.rpm                                                                                                    |  88 kB  00:00:00     
    (15/59): elfutils-libelf-0.176-2.el7.x86_64.rpm                                                                                              | 194 kB  00:00:01     
    (16/59): elfutils-0.176-2.el7.x86_64.rpm                                                                                                     | 305 kB  00:00:02     
    (17/59): emacs-filesystem-24.3-22.el7.noarch.rpm                                                                                             |  58 kB  00:00:00     
    (18/59): flex-2.5.37-6.el7.x86_64.rpm                                                                                                        | 293 kB  00:00:01     
    (19/59): elfutils-libs-0.176-2.el7.x86_64.rpm                                                                                                | 291 kB  00:00:08     
    (20/59): dyninst-9.3.1-3.el7.x86_64.rpm                                                                                                      | 3.5 MB  00:00:27     
    (21/59): gdb-7.6.1-115.el7.x86_64.rpm                                                                                                        | 2.4 MB  00:00:21     
    (22/59): gettext-common-devel-0.19.8.1-2.el7.noarch.rpm                                                                                      | 410 kB  00:00:03     
    (23/59): indent-2.2.11-13.el7.x86_64.rpm                                                                                                     | 150 kB  00:00:01     
    (24/59): intltool-0.50.2-7.el7.noarch.rpm                                                                                                    |  59 kB  00:00:00     
    (25/59): gettext-devel-0.19.8.1-2.el7.x86_64.rpm                                                                                             | 320 kB  00:00:02     
    (26/59): libdwarf-20130207-4.el7.x86_64.rpm                                                                                                  | 109 kB  00:00:00     
    (27/59): libgfortran-4.8.5-39.el7.x86_64.rpm                                                                                                 | 300 kB  00:00:02     
    (28/59): libquadmath-4.8.5-39.el7.x86_64.rpm                                                                                                 | 190 kB  00:00:01     
    (29/59): libquadmath-devel-4.8.5-39.el7.x86_64.rpm                                                                                           |  53 kB  00:00:00     
    (30/59): libstdc++-4.8.5-39.el7.x86_64.rpm                                                                                                   | 305 kB  00:00:01     
    (31/59): libstdc++-devel-4.8.5-39.el7.x86_64.rpm                                                                                             | 1.5 MB  00:00:10     
    (32/59): libtool-2.4.2-22.el7_3.x86_64.rpm                                                                                                   | 588 kB  00:00:03     
    (33/59): m4-1.4.16-10.el7.x86_64.rpm                                                                                                         | 256 kB  00:00:01     
    (34/59): gcc-gfortran-4.8.5-39.el7.x86_64.rpm                                                                                                | 6.7 MB  00:00:52     
    (35/59): mokutil-15-2.el7.centos.x86_64.rpm                                                                                                  |  42 kB  00:00:00     
    (36/59): patchutils-0.3.3-4.el7.x86_64.rpm                                                                                                   | 104 kB  00:00:00     
    (37/59): patch-2.7.1-11.el7.x86_64.rpm                                                                                                       | 110 kB  00:00:01     
    (38/59): perl-Thread-Queue-3.02-2.el7.noarch.rpm                                                                                             |  17 kB  00:00:00     
    (39/59): perl-XML-Parser-2.41-10.el7.x86_64.rpm                                                                                              | 223 kB  00:00:01     
    (40/59): perl-srpm-macros-1-8.el7.noarch.rpm                                                                                                 | 4.6 kB  00:00:00     
    (41/59): rcs-5.9.0-5.el7.x86_64.rpm                                                                                                          | 230 kB  00:00:01     
    (42/59): redhat-rpm-config-9.1.0-88.el7.centos.noarch.rpm                                                                                    |  81 kB  00:00:00     
    (43/59): doxygen-1.8.5-3.el7.x86_64.rpm                                                                                                      | 3.6 MB  00:01:06     
    (44/59): rpm-build-4.11.3-40.el7.x86_64.rpm                                                                                                  | 149 kB  00:00:01     
    (45/59): rpm-build-libs-4.11.3-40.el7.x86_64.rpm                                                                                             | 107 kB  00:00:00     
    (46/59): rpm-4.11.3-40.el7.x86_64.rpm                                                                                                        | 1.2 MB  00:00:07     
    (47/59): rpm-libs-4.11.3-40.el7.x86_64.rpm                                                                                                   | 278 kB  00:00:01     
    (48/59): rpm-python-4.11.3-40.el7.x86_64.rpm                                                                                                 |  83 kB  00:00:00     
    (49/59): rpm-sign-4.11.3-40.el7.x86_64.rpm                                                                                                   |  48 kB  00:00:00     
    (50/59): systemtap-4.0-9.el7.x86_64.rpm                                                                                                      |  15 kB  00:00:00     
    (51/59): perl-Test-Harness-3.28-3.el7.noarch.rpm                                                                                             | 302 kB  00:00:20     
    (52/59): swig-2.0.10-5.el7.x86_64.rpm                                                                                                        | 1.3 MB  00:00:12     
    (53/59): systemtap-runtime-4.0-9.el7.x86_64.rpm                                                                                              | 443 kB  00:00:05     
    (54/59): unzip-6.0-20.el7.x86_64.rpm                                                                                                         | 170 kB  00:00:01     
    (55/59): zip-3.0-11.el7.x86_64.rpm                                                                                                           | 260 kB  00:00:02     
    (56/59): systemtap-devel-4.0-9.el7.x86_64.rpm                                                                                                | 2.2 MB  00:00:20     
    (57/59): systemtap-client-4.0-9.el7.x86_64.rpm                                                                                               | 3.6 MB  00:00:29     
    (58/59): gcc-c++-4.8.5-39.el7.x86_64.rpm                                                                                                     | 7.2 MB  00:01:39     
    (59/59): kernel-debug-devel-3.10.0-1062.1.1.el7.x86_64.rpm                                                                                   |  18 MB  00:01:40     
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------
    总计                                                                                                                                438 kB/s |  60 MB  00:02:20     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在更新    : elfutils-libelf-0.176-2.el7.x86_64                                                                                                             1/66 
    正在更新    : libstdc++-4.8.5-39.el7.x86_64                                                                                                                  2/66 
    正在更新    : rpm-4.11.3-40.el7.x86_64                                                                                                                       3/66 
    正在更新    : rpm-libs-4.11.3-40.el7.x86_64                                                                                                                  4/66 
    正在更新    : rpm-build-libs-4.11.3-40.el7.x86_64                                                                                                            5/66 
    正在更新    : elfutils-libs-0.176-2.el7.x86_64                                                                                                               6/66 
    正在安装    : libquadmath-4.8.5-39.el7.x86_64                                                                                                                7/66 
    正在安装    : m4-1.4.16-10.el7.x86_64                                                                                                                        8/66 
    正在安装    : autoconf-2.69-11.el7.noarch                                                                                                                    9/66 
    正在安装    : boost-system-1.53.0-27.el7.x86_64                                                                                                             10/66 
    正在安装    : unzip-6.0-20.el7.x86_64                                                                                                                       11/66 
    正在安装    : perl-Thread-Queue-3.02-2.el7.noarch                                                                                                           12/66 
    正在安装    : avahi-libs-0.6.31-19.el7.x86_64                                                                                                               13/66 
    正在安装    : zip-3.0-11.el7.x86_64                                                                                                                         14/66 
    正在安装    : patch-2.7.1-11.el7.x86_64                                                                                                                     15/66 
    正在安装    : boost-thread-1.53.0-27.el7.x86_64                                                                                                             16/66 
    正在安装    : libgfortran-4.8.5-39.el7.x86_64                                                                                                               17/66 
    正在安装    : libquadmath-devel-4.8.5-39.el7.x86_64                                                                                                         18/66 
    正在安装    : elfutils-0.176-2.el7.x86_64                                                                                                                   19/66 
    正在安装    : libstdc++-devel-4.8.5-39.el7.x86_64                                                                                                           20/66 
    正在安装    : boost-date-time-1.53.0-27.el7.x86_64                                                                                                          21/66 
    正在安装    : dwz-0.11-3.el7.x86_64                                                                                                                         22/66 
    正在安装    : libdwarf-20130207-4.el7.x86_64                                                                                                                23/66 
    正在安装    : dyninst-9.3.1-3.el7.x86_64                                                                                                                    24/66 
    正在安装    : systemtap-runtime-4.0-9.el7.x86_64                                                                                                            25/66 
    正在安装    : perl-srpm-macros-1-8.el7.noarch                                                                                                               26/66 
    正在安装    : redhat-rpm-config-9.1.0-88.el7.centos.noarch                                                                                                  27/66 
    正在安装    : gdb-7.6.1-115.el7.x86_64                                                                                                                      28/66 
    正在安装    : kernel-debug-devel-3.10.0-1062.1.1.el7.x86_64                                                                                                 29/66 
    正在安装    : systemtap-devel-4.0-9.el7.x86_64                                                                                                              30/66 
    正在安装    : perl-XML-Parser-2.41-10.el7.x86_64                                                                                                            31/66 
    正在安装    : gettext-common-devel-0.19.8.1-2.el7.noarch                                                                                                    32/66 
    正在安装    : gettext-devel-0.19.8.1-2.el7.x86_64                                                                                                           33/66 
    正在安装    : perl-Test-Harness-3.28-3.el7.noarch                                                                                                           34/66 
    正在安装    : automake-1.13.4-3.el7.noarch                                                                                                                  35/66 
    正在安装    : bzip2-1.0.6-13.el7.x86_64                                                                                                                     36/66 
    正在安装    : 1:emacs-filesystem-24.3-22.el7.noarch                                                                                                         37/66 
    正在安装    : efivar-libs-36-12.el7.x86_64                                                                                                                  38/66 
    正在安装    : mokutil-15-2.el7.centos.x86_64                                                                                                                39/66 
    正在安装    : systemtap-client-4.0-9.el7.x86_64                                                                                                             40/66 
    正在安装    : systemtap-4.0-9.el7.x86_64                                                                                                                    41/66 
    正在安装    : cscope-15.8-10.el7.x86_64                                                                                                                     42/66 
    正在安装    : rpm-build-4.11.3-40.el7.x86_64                                                                                                                43/66 
    正在安装    : intltool-0.50.2-7.el7.noarch                                                                                                                  44/66 
    正在安装    : libtool-2.4.2-22.el7_3.x86_64                                                                                                                 45/66 
    正在安装    : gcc-c++-4.8.5-39.el7.x86_64                                                                                                                   46/66 
    正在安装    : gcc-gfortran-4.8.5-39.el7.x86_64                                                                                                              47/66 
    正在安装    : flex-2.5.37-6.el7.x86_64                                                                                                                      48/66 
    正在安装    : bison-3.0.4-2.el7.x86_64                                                                                                                      49/66 
    正在更新    : rpm-python-4.11.3-40.el7.x86_64                                                                                                               50/66 
    正在安装    : rpm-sign-4.11.3-40.el7.x86_64                                                                                                                 51/66 
    正在安装    : 1:doxygen-1.8.5-3.el7.x86_64                                                                                                                  52/66 
    正在安装    : swig-2.0.10-5.el7.x86_64                                                                                                                      53/66 
    正在安装    : diffstat-1.57-4.el7.x86_64                                                                                                                    54/66 
    正在安装    : patchutils-0.3.3-4.el7.x86_64                                                                                                                 55/66 
    正在安装    : indent-2.2.11-13.el7.x86_64                                                                                                                   56/66 
    正在安装    : rcs-5.9.0-5.el7.x86_64                                                                                                                        57/66 
    正在安装    : byacc-1.9.20130304-3.el7.x86_64                                                                                                               58/66 
    正在安装    : ctags-5.8-13.el7.x86_64                                                                                                                       59/66 
    清理        : rpm-python-4.11.3-35.el7.x86_64                                                                                                               60/66 
    清理        : rpm-build-libs-4.11.3-35.el7.x86_64                                                                                                           61/66 
    清理        : rpm-4.11.3-35.el7.x86_64                                                                                                                      62/66 
    清理        : rpm-libs-4.11.3-35.el7.x86_64                                                                                                                 63/66 
    清理        : elfutils-libs-0.172-2.el7.x86_64                                                                                                              64/66 
    清理        : elfutils-libelf-0.172-2.el7.x86_64                                                                                                            65/66 
    清理        : libstdc++-4.8.5-36.el7.x86_64                                                                                                                 66/66 
    验证中      : ctags-5.8-13.el7.x86_64                                                                                                                        1/66 
    验证中      : systemtap-4.0-9.el7.x86_64                                                                                                                     2/66 
    验证中      : patch-2.7.1-11.el7.x86_64                                                                                                                      3/66 
    验证中      : gettext-devel-0.19.8.1-2.el7.x86_64                                                                                                            4/66 
    验证中      : zip-3.0-11.el7.x86_64                                                                                                                          5/66 
    验证中      : byacc-1.9.20130304-3.el7.x86_64                                                                                                                6/66 
    验证中      : libgfortran-4.8.5-39.el7.x86_64                                                                                                                7/66 
    验证中      : efivar-libs-36-12.el7.x86_64                                                                                                                   8/66 
    验证中      : boost-system-1.53.0-27.el7.x86_64                                                                                                              9/66 
    验证中      : automake-1.13.4-3.el7.noarch                                                                                                                  10/66 
    验证中      : 1:emacs-filesystem-24.3-22.el7.noarch                                                                                                         11/66 
    验证中      : m4-1.4.16-10.el7.x86_64                                                                                                                       12/66 
    验证中      : libstdc++-devel-4.8.5-39.el7.x86_64                                                                                                           13/66 
    验证中      : systemtap-client-4.0-9.el7.x86_64                                                                                                             14/66 
    验证中      : libstdc++-4.8.5-39.el7.x86_64                                                                                                                 15/66 
    验证中      : 1:doxygen-1.8.5-3.el7.x86_64                                                                                                                  16/66 
    验证中      : avahi-libs-0.6.31-19.el7.x86_64                                                                                                               17/66 
    验证中      : rpm-build-libs-4.11.3-40.el7.x86_64                                                                                                           18/66 
    验证中      : bzip2-1.0.6-13.el7.x86_64                                                                                                                     19/66 
    验证中      : perl-Test-Harness-3.28-3.el7.noarch                                                                                                           20/66 
    验证中      : boost-thread-1.53.0-27.el7.x86_64                                                                                                             21/66 
    验证中      : perl-Thread-Queue-3.02-2.el7.noarch                                                                                                           22/66 
    验证中      : systemtap-devel-4.0-9.el7.x86_64                                                                                                              23/66 
    验证中      : intltool-0.50.2-7.el7.noarch                                                                                                                  24/66 
    验证中      : rcs-5.9.0-5.el7.x86_64                                                                                                                        25/66 
    验证中      : swig-2.0.10-5.el7.x86_64                                                                                                                      26/66 
    验证中      : gettext-common-devel-0.19.8.1-2.el7.noarch                                                                                                    27/66 
    验证中      : libtool-2.4.2-22.el7_3.x86_64                                                                                                                 28/66 
    验证中      : gcc-c++-4.8.5-39.el7.x86_64                                                                                                                   29/66 
    验证中      : rpm-python-4.11.3-40.el7.x86_64                                                                                                               30/66 
    验证中      : dyninst-9.3.1-3.el7.x86_64                                                                                                                    31/66 
    验证中      : rpm-build-4.11.3-40.el7.x86_64                                                                                                                32/66 
    验证中      : indent-2.2.11-13.el7.x86_64                                                                                                                   33/66 
    验证中      : perl-XML-Parser-2.41-10.el7.x86_64                                                                                                            34/66 
    验证中      : gcc-gfortran-4.8.5-39.el7.x86_64                                                                                                              35/66 
    验证中      : flex-2.5.37-6.el7.x86_64                                                                                                                      36/66 
    验证中      : rpm-libs-4.11.3-40.el7.x86_64                                                                                                                 37/66 
    验证中      : libquadmath-devel-4.8.5-39.el7.x86_64                                                                                                         38/66 
    验证中      : unzip-6.0-20.el7.x86_64                                                                                                                       39/66 
    验证中      : patchutils-0.3.3-4.el7.x86_64                                                                                                                 40/66 
    验证中      : kernel-debug-devel-3.10.0-1062.1.1.el7.x86_64                                                                                                 41/66 
    验证中      : cscope-15.8-10.el7.x86_64                                                                                                                     42/66 
    验证中      : bison-3.0.4-2.el7.x86_64                                                                                                                      43/66 
    验证中      : mokutil-15-2.el7.centos.x86_64                                                                                                                44/66 
    验证中      : systemtap-runtime-4.0-9.el7.x86_64                                                                                                            45/66 
    验证中      : autoconf-2.69-11.el7.noarch                                                                                                                   46/66 
    验证中      : elfutils-0.176-2.el7.x86_64                                                                                                                   47/66 
    验证中      : rpm-4.11.3-40.el7.x86_64                                                                                                                      48/66 
    验证中      : elfutils-libs-0.176-2.el7.x86_64                                                                                                              49/66 
    验证中      : libquadmath-4.8.5-39.el7.x86_64                                                                                                               50/66 
    验证中      : boost-date-time-1.53.0-27.el7.x86_64                                                                                                          51/66 
    验证中      : gdb-7.6.1-115.el7.x86_64                                                                                                                      52/66 
    验证中      : dwz-0.11-3.el7.x86_64                                                                                                                         53/66 
    验证中      : diffstat-1.57-4.el7.x86_64                                                                                                                    54/66 
    验证中      : elfutils-libelf-0.176-2.el7.x86_64                                                                                                            55/66 
    验证中      : libdwarf-20130207-4.el7.x86_64                                                                                                                56/66 
    验证中      : rpm-sign-4.11.3-40.el7.x86_64                                                                                                                 57/66 
    验证中      : perl-srpm-macros-1-8.el7.noarch                                                                                                               58/66 
    验证中      : redhat-rpm-config-9.1.0-88.el7.centos.noarch                                                                                                  59/66 
    验证中      : elfutils-libelf-0.172-2.el7.x86_64                                                                                                            60/66 
    验证中      : rpm-libs-4.11.3-35.el7.x86_64                                                                                                                 61/66 
    验证中      : libstdc++-4.8.5-36.el7.x86_64                                                                                                                 62/66 
    验证中      : rpm-4.11.3-35.el7.x86_64                                                                                                                      63/66 
    验证中      : rpm-build-libs-4.11.3-35.el7.x86_64                                                                                                           64/66 
    验证中      : elfutils-libs-0.172-2.el7.x86_64                                                                                                              65/66 
    验证中      : rpm-python-4.11.3-35.el7.x86_64                                                                                                               66/66 

    已安装:
    autoconf.noarch 0:2.69-11.el7       automake.noarch 0:1.13.4-3.el7     bison.x86_64 0:3.0.4-2.el7                         byacc.x86_64 0:1.9.20130304-3.el7     
    cscope.x86_64 0:15.8-10.el7         ctags.x86_64 0:5.8-13.el7          diffstat.x86_64 0:1.57-4.el7                       doxygen.x86_64 1:1.8.5-3.el7          
    elfutils.x86_64 0:0.176-2.el7       flex.x86_64 0:2.5.37-6.el7         gcc-c++.x86_64 0:4.8.5-39.el7                      gcc-gfortran.x86_64 0:4.8.5-39.el7    
    indent.x86_64 0:2.2.11-13.el7       intltool.noarch 0:0.50.2-7.el7     libtool.x86_64 0:2.4.2-22.el7_3                    patch.x86_64 0:2.7.1-11.el7           
    patchutils.x86_64 0:0.3.3-4.el7     rcs.x86_64 0:5.9.0-5.el7           redhat-rpm-config.noarch 0:9.1.0-88.el7.centos     rpm-build.x86_64 0:4.11.3-40.el7      
    rpm-sign.x86_64 0:4.11.3-40.el7     swig.x86_64 0:2.0.10-5.el7         systemtap.x86_64 0:4.0-9.el7                      

    作为依赖被安装:
    avahi-libs.x86_64 0:0.6.31-19.el7                         boost-date-time.x86_64 0:1.53.0-27.el7                 boost-system.x86_64 0:1.53.0-27.el7            
    boost-thread.x86_64 0:1.53.0-27.el7                       bzip2.x86_64 0:1.0.6-13.el7                            dwz.x86_64 0:0.11-3.el7                        
    dyninst.x86_64 0:9.3.1-3.el7                              efivar-libs.x86_64 0:36-12.el7                         emacs-filesystem.noarch 1:24.3-22.el7          
    gdb.x86_64 0:7.6.1-115.el7                                gettext-common-devel.noarch 0:0.19.8.1-2.el7           gettext-devel.x86_64 0:0.19.8.1-2.el7          
    kernel-debug-devel.x86_64 0:3.10.0-1062.1.1.el7           libdwarf.x86_64 0:20130207-4.el7                       libgfortran.x86_64 0:4.8.5-39.el7              
    libquadmath.x86_64 0:4.8.5-39.el7                         libquadmath-devel.x86_64 0:4.8.5-39.el7                libstdc++-devel.x86_64 0:4.8.5-39.el7          
    m4.x86_64 0:1.4.16-10.el7                                 mokutil.x86_64 0:15-2.el7.centos                       perl-Test-Harness.noarch 0:3.28-3.el7          
    perl-Thread-Queue.noarch 0:3.02-2.el7                     perl-XML-Parser.x86_64 0:2.41-10.el7                   perl-srpm-macros.noarch 0:1-8.el7              
    systemtap-client.x86_64 0:4.0-9.el7                       systemtap-devel.x86_64 0:4.0-9.el7                     systemtap-runtime.x86_64 0:4.0-9.el7           
    unzip.x86_64 0:6.0-20.el7                                 zip.x86_64 0:3.0-11.el7                               

    作为依赖被升级:
    elfutils-libelf.x86_64 0:0.176-2.el7         elfutils-libs.x86_64 0:0.176-2.el7        libstdc++.x86_64 0:4.8.5-39.el7          rpm.x86_64 0:4.11.3-40.el7       
    rpm-build-libs.x86_64 0:4.11.3-40.el7        rpm-libs.x86_64 0:4.11.3-40.el7           rpm-python.x86_64 0:4.11.3-40.el7       

    完毕!
    [[email?protected] open-falcon]# pi
    pic              pidof            pinentry         ping             pinky            
    piconv           pidstat          pinentry-curses  ping6            pivot_root       
    [[email?protected] open-falcon]# yum -y install pip
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    没有可用软件包 pip。
    错误:无须任何处理
    [[email?protected] open-falcon]# yum -y install python-pip
    已加载插件:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.huaweicloud.com
    * epel: mirrors.tuna.tsinghua.edu.cn
    * extras: mirrors.163.com
    * updates: mirrors.163.com
    正在解决依赖关系
    --> 正在检查事务
    ---> 软件包 python2-pip.noarch.0.8.1.2-10.el7 将被 安装
    --> 解决依赖关系完成

    依赖关系解决

    ====================================================================================================================================================================
    Package                                   架构                                 版本                                       源                                  大小
    ====================================================================================================================================================================
    正在安装:
    python2-pip                               noarch                               8.1.2-10.el7                               epel                               1.7 M

    事务概要
    ====================================================================================================================================================================
    安装  1 软件包

    总下载量:1.7 M
    安装大小:7.2 M
    Downloading packages:
    python2-pip-8.1.2-10.el7.noarch.rpm                                                                                                          | 1.7 MB  00:00:06     
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    正在安装    : python2-pip-8.1.2-10.el7.noarch                                                                                                                 1/1 
    验证中      : python2-pip-8.1.2-10.el7.noarch                                                                                                                 1/1 

    已安装:
    python2-pip.noarch 0:8.1.2-10.el7                                                                                                                                 

    完毕!
    [[email?protected] open-falcon]# pi
    pic              pidof            pinentry         ping             pinky            pip2             pivot_root       
    piconv           pidstat          pinentry-curses  ping6            pip              pip2.7           
    [[email?protected] open-falcon]# cd dashboard/            
    [[email?protected] dashboard]# virtualenv ./env
    New python executable in /home/work/open-falcon/dashboard/env/bin/python
    Installing setuptools, pip, wheel...done.
    [[email?protected] dashboard]# ./env/bin/pip install -r pip_requirements.txt
    Collecting Flask==1.0 (from -r pip_requirements.txt (line 1))
    Downloading https://files.pythonhosted.org/packages/55/b1/4365193655df97227ace49311365cc296e74b60c7f5c63d23cd30175e2f6/Flask-1.0-py2.py3-none-any.whl (97kB)
        100% |████████████████████████████████| 102kB 317kB/s 
    Collecting Flask-Babel==0.9 (from -r pip_requirements.txt (line 2))
    Downloading https://files.pythonhosted.org/packages/24/6b/dd9031c446e05600b740086274a9939799f26401b8b96e124ccf71e6a9b2/Flask-Babel-0.9.tar.gz
    Collecting Jinja2>=2.10.1 (from -r pip_requirements.txt (line 3))
    Downloading https://files.pythonhosted.org/packages/1d/e7/fd8b501e7a6dfe492a433deb7b9d833d39ca74916fa8bc63dd1a4947a671/Jinja2-2.10.1-py2.py3-none-any.whl (124kB)
        100% |████████████████████████████████| 133kB 388kB/s 
    Collecting Werkzeug==0.15.4 (from -r pip_requirements.txt (line 4))
    Downloading https://files.pythonhosted.org/packages/9f/57/92a497e38161ce40606c27a86759c6b92dd34fcdb33f64171ec559257c02/Werkzeug-0.15.4-py2.py3-none-any.whl (327kB)
        100% |████████████████████████████████| 327kB 362kB/s 
    Collecting gunicorn==19.9.0 (from -r pip_requirements.txt (line 5))
    Downloading https://files.pythonhosted.org/packages/8c/da/b8dd8deb741bff556db53902d4706774c8e1e67265f69528c14c003644e6/gunicorn-19.9.0-py2.py3-none-any.whl (112kB)
        100% |████████████████████████████████| 122kB 399kB/s 
    Collecting python-dateutil==2.2 (from -r pip_requirements.txt (line 6))
    Downloading https://files.pythonhosted.org/packages/75/c5/85d027471fa665f8c8b8eb0b925f9d84b4eee745a257b16de4957de99e81/python-dateutil-2.2.tar.gz (259kB)
        100% |████████████████████████████████| 266kB 379kB/s 
    Collecting requests==2.3.0 (from -r pip_requirements.txt (line 7))
    Downloading https://files.pythonhosted.org/packages/f7/51/7aa1e337862118bee783c0249debd64cb07b8fbdfef154b1e185754b02d5/requests-2.3.0-py2.py3-none-any.whl (452kB)
        100% |████████████████████████████████| 460kB 343kB/s 
    Collecting mysql-python (from -r pip_requirements.txt (line 8))
    Downloading https://files.pythonhosted.org/packages/a5/e9/51b544da85a36a68debe7a7091f068d802fc515a3a202652828c73453cad/MySQL-python-1.2.5.zip (108kB)
        100% |████████████████████████████████| 112kB 414kB/s 
    Collecting python-ldap (from -r pip_requirements.txt (line 9))
    Downloading https://files.pythonhosted.org/packages/ea/93/596f875e003c770447f4b99267820a0c769dd2dc3ae3ed19afe460fcbad0/python-ldap-3.2.0.tar.gz (367kB)
        100% |████████████████████████████████| 368kB 355kB/s 
    Collecting click>=5.1 (from Flask==1.0->-r pip_requirements.txt (line 1))
    Downloading https://files.pythonhosted.org/packages/fa/37/45185cb5abbc30d7257104c434fe0b07e5a195a6847506c074527aa599ec/Click-7.0-py2.py3-none-any.whl (81kB)
        100% |████████████████████████████████| 81kB 515kB/s 
    Collecting itsdangerous>=0.24 (from Flask==1.0->-r pip_requirements.txt (line 1))
    Downloading https://files.pythonhosted.org/packages/76/ae/44b03b253d6fade317f32c24d100b3b35c2239807046a4c953c7b89fa49e/itsdangerous-1.1.0-py2.py3-none-any.whl
    Collecting Babel>=1.0 (from Flask-Babel==0.9->-r pip_requirements.txt (line 2))
    Downloading https://files.pythonhosted.org/packages/2c/60/f2af68eb046c5de5b1fe6dd4743bf42c074f7141fe7b2737d3061533b093/Babel-2.7.0-py2.py3-none-any.whl (8.4MB)
        100% |████████████████████████████████| 8.4MB 68kB/s 
    Collecting speaklater>=1.2 (from Flask-Babel==0.9->-r pip_requirements.txt (line 2))
    Downloading https://files.pythonhosted.org/packages/11/92/5ae1effe0ccb8561c034a0111d53c8788660ddb7ed4992f0da1bb5c525e5/speaklater-1.3.tar.gz
    Collecting MarkupSafe>=0.23 (from Jinja2>=2.10.1->-r pip_requirements.txt (line 3))
    Downloading https://files.pythonhosted.org/packages/fb/40/f3adb7cf24a8012813c5edb20329eb22d5d8e2a0ecf73d21d6b85865da11/MarkupSafe-1.1.1-cp27-cp27mu-manylinux1_x86_64.whl
    Collecting six (from python-dateutil==2.2->-r pip_requirements.txt (line 6))
    Downloading https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
    Collecting pyasn1>=0.3.7 (from python-ldap->-r pip_requirements.txt (line 9))
    Downloading https://files.pythonhosted.org/packages/a1/71/8f0d444e3a74e5640a3d5d967c1c6b015da9c655f35b2d308a55d907a517/pyasn1-0.4.7-py2.py3-none-any.whl (76kB)
        100% |████████████████████████████████| 81kB 442kB/s 
    Collecting pyasn1_modules>=0.1.5 (from python-ldap->-r pip_requirements.txt (line 9))
    Downloading https://files.pythonhosted.org/packages/be/70/e5ea8afd6d08a4b99ebfc77bd1845248d56cfcf43d11f9dc324b9580a35c/pyasn1_modules-0.2.6-py2.py3-none-any.whl (95kB)
        100% |████████████████████████████████| 102kB 457kB/s 
    Collecting pytz>=2015.7 (from Babel>=1.0->Flask-Babel==0.9->-r pip_requirements.txt (line 2))
    Downloading https://files.pythonhosted.org/packages/87/76/46d697698a143e05f77bec5a526bf4e56a0be61d63425b68f4ba553b51f2/pytz-2019.2-py2.py3-none-any.whl (508kB)
        100% |████████████████████████████████| 512kB 359kB/s 
    Building wheels for collected packages: Flask-Babel, python-dateutil, mysql-python, python-ldap, speaklater
    Running setup.py bdist_wheel for Flask-Babel ... done
    Stored in directory: /home/work/.cache/pip/wheels/a6/d2/67/2f7dbec3de6a98c119860b9a7203cafea731a3d41c5c91c617
    Running setup.py bdist_wheel for python-dateutil ... done
    Stored in directory: /home/work/.cache/pip/wheels/97/40/49/e02356db91efa7a5da28ec2e5c61f0fb2c0aa21bbd5da95805
    Running setup.py bdist_wheel for mysql-python ... done
    Stored in directory: /home/work/.cache/pip/wheels/07/d2/5f/314860e4cb53a44bf0ee0d051d4b34465e4b4fbe9de6d42f42
    Running setup.py bdist_wheel for python-ldap ... done
    Stored in directory: /home/work/.cache/pip/wheels/48/dd/0b/a06d1baf6575ad4520fc1fcf5bd96b493cd89670fdf6ade224
    Running setup.py bdist_wheel for speaklater ... done
    Stored in directory: /home/work/.cache/pip/wheels/c4/f3/2d/57f871bb1786128515c7c5343fefe345e1df68f4b6317b897d
    Successfully built Flask-Babel python-dateutil mysql-python python-ldap speaklater
    Installing collected packages: Werkzeug, click, itsdangerous, MarkupSafe, Jinja2, Flask, pytz, Babel, speaklater, Flask-Babel, gunicorn, six, python-dateutil, requests, mysql-python, pyasn1, pyasn1-modules, python-ldap
    Successfully installed Babel-2.7.0 Flask-1.0 Flask-Babel-0.9 Jinja2-2.10.1 MarkupSafe-1.1.1 Werkzeug-0.15.4 click-7.0 gunicorn-19.9.0 itsdangerous-1.1.0 mysql-python-1.2.5 pyasn1-0.4.7 pyasn1-modules-0.2.6 python-dateutil-2.2 python-ldap-3.2.0 pytz-2019.2 requests-2.3.0 six-1.12.0 speaklater-1.3
    You are using pip version 9.0.1, however version 19.2.3 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    [[email?protected] dashboard]# pip install --upgrade pip
    Collecting pip
    Downloading https://files.pythonhosted.org/packages/30/db/9e38760b32e3e7f40cce46dd5fb107b8c73840df38f0046d8e6514e675a1/pip-19.2.3-py2.py3-none-any.whl (1.4MB)
        100% |████████████████████████████████| 1.4MB 218kB/s 
    Installing collected packages: pip
    Found existing installation: pip 8.1.2
        Uninstalling pip-8.1.2:
        Successfully uninstalled pip-8.1.2
    Successfully installed pip-19.2.3
    [[email?protected] dashboard]# cp rrd/config.py{,.bak}
    [[email?protected] dashboard]# vim rrd/config.py
    #-*-coding:utf-8 -*-
    # Copyright 2017 Xiaomi, Inc.
    #
    # Licensed under the Apache License, Version 2.0 (the "License");
    # you may not use this file except in compliance with the License.
    # You may obtain a copy of the License at
    #
    #     http://www.apache.org/licenses/LICENSE-2.0
    #
    # Unless required by applicable law or agreed to in writing, software
    # distributed under the License is distributed on an "AS IS" BASIS,
    # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
    # See the License for the specific language governing permissions and
    # limitations under the License.

    # app config
    import os
    LOG_LEVEL = os.environ.get("LOG_LEVEL",'DEBUG')
    SECRET_KEY = os.environ.get("SECRET_KEY","secret-key")
    PERMANENT_SESSION_LIFETIME = os.environ.get("PERMANENT_SESSION_LIFETIME",3600 * 24 * 30)
    SITE_COOKIE = os.environ.get("SITE_COOKIE","open-falcon-ck")

    # Falcon+ API
    API_ADDR = os.environ.get("API_ADDR","http://127.0.0.1:8080/api/v1")
    API_USER = os.environ.get("API_USER","admin")
    API_PASS = os.environ.get("API_PASS","password")

    # portal database
    # TODO: read from api instead of db
    PORTAL_DB_HOST = os.environ.get("PORTAL_DB_HOST","127.0.0.1")
    PORTAL_DB_PORT = int(os.environ.get("PORTAL_DB_PORT",3306))
    PORTAL_DB_USER = os.environ.get("PORTAL_DB_USER","falcon")
    PORTAL_DB_PASS = os.environ.get("PORTAL_DB_PASS","falcon")
    PORTAL_DB_NAME = os.environ.get("PORTAL_DB_NAME","falcon_portal")

    # alarm database
    # TODO: read from api instead of db
    ALARM_DB_HOST = os.environ.get("ALARM_DB_HOST","127.0.0.1")
    ALARM_DB_PORT = int(os.environ.get("ALARM_DB_PORT",3306))
    ALARM_DB_USER = os.environ.get("ALARM_DB_USER","root")
    ALARM_DB_PASS = os.environ.get("ALARM_DB_PASS","")
    "rrd/config.py" 79L, 2755C 已写入                                                                                                                 
    [[email?protected] dashboard]# ll
    总用量 56
    -rw-r--r--.  1 root root    97 9月  18 17:48 babel.cfg
    -rwxr-xr-x.  1 root root  2653 9月  18 17:48 control
    -rw-r--r--.  1 root root   510 9月  18 17:48 Dockerfile
    -rw-r--r--.  1 root root   319 9月  18 17:48 entrypoint.sh
    drwxr-xr-x.  5 root root    82 9月  18 17:58 env
    -rw-r--r--.  1 root root   170 9月  18 17:48 gunicorn.conf
    -rw-r--r--.  1 root root  1235 9月  18 17:48 i18n.md
    -rw-r--r--.  1 root root 11358 9月  18 17:48 LICENSE
    -rw-r--r--.  1 root root   462 9月  18 17:48 NOTICE
    -rw-r--r--.  1 root root   139 9月  18 17:48 pip_requirements.txt
    -rw-r--r--.  1 root root  5296 9月  18 17:48 README.md
    drwxr-xr-x. 10 root root   215 9月  18 18:03 rrd
    drwxr-xr-x.  2 root root   101 9月  18 17:48 screenshots
    drwxr-xr-x.  2 root root    65 9月  18 17:48 scripts
    -rwxr-xr-x.  1 root root   979 9月  18 17:48 wsgi.py
    [[email?protected] dashboard]# source env/bin/activate
    (env) [[email?protected] dashboard]# ./control start
    falcon-dashboard started..., pid=1635
    (env) [[email?protected] dashboard]# netstat  -nltp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
    tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      13359/mysqld        
    tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      13021/redis-server  
    tcp        0      0 0.0.0.0:8081            0.0.0.0:*               LISTEN      1635/python         
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      3063/sshd           
    tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      3278/master         
    tcp6       0      0 :::6055                 :::*                    LISTEN      19925/falcon-aggreg 
    tcp6       0      0 :::6090                 :::*                    LISTEN      19917/falcon-nodata 
    tcp6       0      0 :::14444                :::*                    LISTEN      19943/falcon-gatewa 
    tcp6       0      0 :::6060                 :::*                    LISTEN      19910/falcon-transf 
    tcp6       0      0 :::6030                 :::*                    LISTEN      19894/falcon-hbs    
    tcp6       0      0 :::6031                 :::*                    LISTEN      19894/falcon-hbs    
    tcp6       0      0 :::8080                 :::*                    LISTEN      19950/falcon-api    
    tcp6       0      0 :::8433                 :::*                    LISTEN      19910/falcon-transf 
    tcp6       0      0 :::6070                 :::*                    LISTEN      19882/falcon-graph  
    tcp6       0      0 :::22                   :::*                    LISTEN      3063/sshd           
    tcp6       0      0 :::6071                 :::*                    LISTEN      19882/falcon-graph  
    tcp6       0      0 :::9912                 :::*                    LISTEN      19963/falcon-alarm  
    tcp6       0      0 ::1:25                  :::*                    LISTEN      3278/master         
    tcp6       0      0 :::16060                :::*                    LISTEN      19943/falcon-gatewa 
    tcp6       0      0 :::4444                 :::*                    LISTEN      19910/falcon-transf 
    tcp6       0      0 :::6080                 :::*                    LISTEN      19903/falcon-judge  
    tcp6       0      0 :::18433                :::*                    LISTEN      19943/falcon-gatewa 
    tcp6       0      0 :::6081                 :::*                    LISTEN      19903/falcon-judge  
    tcp6       0      0 :::1988                 :::*                    LISTEN      19934/falcon-agent  

猜你喜欢

转载自blog.51cto.com/860143/2439057